summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD59
3 files changed, 46 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cd8e8cf0ef0..239a718cef55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
pkgbase = kakoune-git
pkgdesc = Multiple-selection, UNIX-flavored modal editor
- pkgver = v2019.07.01_32_g837416ea
- pkgrel = 1
+ pkgver = 2023.08.05
+ pkgrel = 2
url = https://github.com/mawww/kakoune
arch = x86_64
arch = armv7h
license = custom:unlicense
makedepends = git
- depends = ncurses
- optdepends = aspell: spell checking support
- optdepends = clang: add command for C/CPP insert mode completion support
- optdepends = ranger: provides file explorer functionality
- optdepends = tmux: tabbing support
- optdepends = universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition
- optdepends = xdotool: add support for kak windows switching (in grep, make... files)
- optdepends = xorg-xmessage: for nicer debugging messages
- provides = kakoune
+ depends = gcc-libs
+ optdepends = aspell: spell check, correct text
+ optdepends = clang: error reporting and diagnostics, completion
+ optdepends = ctags-git: complete and describe a symbol, jump to its definition
+ optdepends = editorconfig-core-c: set formatting options project-wide
+ optdepends = git: display and cycle through hunks, blame lines, handle file status
+ optdepends = kak-lsp: Language Server Protocol (LSP) client
+ optdepends = tmux: split windows, spawn tabs
+ optdepends = xdotool: X11 window management
+ optdepends = xorg-xmessage: print detailed crash information in a separate window
+ provides = kakoune=2023.08.05
conflicts = kakoune
+ options = !buildflags
source = kakoune-git::git+https://github.com/mawww/kakoune.git
sha256sums = SKIP
pkgname = kakoune-git
-
diff --git a/.gitignore b/.gitignore
index ac03692f1207..c201c3d783ec 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
-*.pkg.tar.xz
-*.src.tar.gz
-*.src.tar.xz
+*.pkg.tar*
+*.src.tar*
kakoune-git
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index b674cf4d570a..76bc161469b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,48 @@
pkgname=kakoune-git
-pkgver=v2019.07.01_32_g837416ea
-pkgrel=1
-pkgdesc='Multiple-selection, UNIX-flavored modal editor'
-arch=('x86_64' 'armv7h')
-url='https://github.com/mawww/kakoune'
-license=('custom:unlicense')
-depends=(
- 'ncurses'
-)
+pkgver=2023.08.05
+pkgrel=2
+pkgdesc="Multiple-selection, UNIX-flavored modal editor"
+arch=("x86_64" "armv7h")
+url="https://github.com/mawww/kakoune"
+license=("custom:unlicense")
+depends=("gcc-libs")
optdepends=(
- 'aspell: spell checking support'
- 'clang: add command for C/CPP insert mode completion support'
- 'ranger: provides file explorer functionality'
- 'tmux: tabbing support'
- 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition'
- 'xdotool: add support for kak windows switching (in grep, make... files)'
- 'xorg-xmessage: for nicer debugging messages'
+ "aspell: spell check, correct text"
+ "clang: error reporting and diagnostics, completion"
+ "ctags-git: complete and describe a symbol, jump to its definition"
+ "editorconfig-core-c: set formatting options project-wide"
+ "git: display and cycle through hunks, blame lines, handle file status"
+ "kak-lsp: Language Server Protocol (LSP) client"
+ "tmux: split windows, spawn tabs"
+ "xdotool: X11 window management"
+ "xorg-xmessage: print detailed crash information in a separate window"
)
makedepends=(
- 'git'
+ "git"
)
-provides=('kakoune')
-conflicts=('kakoune')
+provides=("kakoune=${pkgver}")
+conflicts=("kakoune")
source=("${pkgname}::git+https://github.com/mawww/kakoune.git")
-sha256sums=('SKIP')
+sha256sums=("SKIP")
+options=("!buildflags")
pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --tags | tr '-' '_'
+ cd "${srcdir}/${pkgname}"
+ git describe --tags | tr "-" "_" | sed "s/^v//; s/_/_r/"
}
check() {
- cd "${srcdir}/${pkgname}/src"
- make test
+ cd "${srcdir}/${pkgname}"
+ make test
}
build() {
- cd "${srcdir}/${pkgname}/src"
- make
+ cd "${srcdir}/${pkgname}"
+ make
}
package() {
- cd "${srcdir}/${pkgname}/src"
- make install-strip DESTDIR="${pkgdir}" PREFIX=/usr
- install -D ../UNLICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ cd "${srcdir}/${pkgname}"
+ make install-strip DESTDIR="${pkgdir}" PREFIX=/usr libexecdir="${pkgdir}"/usr/lib/kak
+ install -D UNLICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}