summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0de337738eca..b1deb3ee2813 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kalk-git
pkgdesc = Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework
- pkgver = v21.05.r0.gb5247dd
+ pkgver = 22.06.r7.g3aeecc7
pkgrel = 1
url = https://invent.kde.org/plasma-mobile/kalk
arch = x86_64
@@ -31,4 +31,3 @@ pkgbase = kalk-git
sha256sums = SKIP
pkgname = kalk-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9a8c5864c753..82d80baed25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kalk-git
-pkgver=v21.05.r0.gb5247dd
+pkgver=22.06.r7.g3aeecc7
pkgrel=1
pkgdesc="Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -18,8 +18,8 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}
@@ -30,4 +30,4 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
-} \ No newline at end of file
+}