summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f4c3a921f76..b1deb3ee2813 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,14 @@
pkgbase = kalk-git
pkgdesc = Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework
- pkgver = v0.2.r70.g09f5754
+ pkgver = 22.06.r7.g3aeecc7
pkgrel = 1
url = https://invent.kde.org/plasma-mobile/kalk
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = qt5-tools
@@ -26,4 +31,3 @@ pkgbase = kalk-git
sha256sums = SKIP
pkgname = kalk-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5aec29435697..82d80baed25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kalk-git
-pkgver=v0.2.r70.g09f5754
+pkgver=22.06.r7.g3aeecc7
pkgrel=1
pkgdesc="Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/plasma-mobile/kalk"
license=('GPL3')
depends=('ki18n' 'kconfig' 'kcoreaddons' 'knotifications' 'kirigami2' 'kunitconversion'
@@ -18,16 +18,16 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}
build() {
- cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
- cmake --build build --config Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
}