summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f4c3a921f76..0de337738eca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,14 @@
pkgbase = kalk-git
pkgdesc = Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework
- pkgver = v0.2.r70.g09f5754
+ pkgver = v21.05.r0.gb5247dd
pkgrel = 1
url = https://invent.kde.org/plasma-mobile/kalk
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = qt5-tools
diff --git a/PKGBUILD b/PKGBUILD
index 5aec29435697..9a8c5864c753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kalk-git
-pkgver=v0.2.r70.g09f5754
+pkgver=v21.05.r0.gb5247dd
pkgrel=1
pkgdesc="Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/plasma-mobile/kalk"
license=('GPL3')
depends=('ki18n' 'kconfig' 'kcoreaddons' 'knotifications' 'kirigami2' 'kunitconversion'
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
- cmake --build build --config Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file