summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 712dfe1be61b..e90dcee2fcb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
-# Generated by mksrcinfo v8
-# Sat Feb 10 17:50:06 UTC 2018
pkgbase = kalu
pkgdesc = Upgrade notifier w/ AUR support, watched (AUR) packages, news
- pkgver = 4.2.0
+ pkgver = 4.5.2
pkgrel = 1
- url = https://jjacky.com/kalu
+ url = https://github.com/Thulinma/kalu
install = kalu.install
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL3+
makedepends = perl
makedepends = groff
depends = dbus
depends = polkit
depends = gtk3
- depends = pacman>=5.0
- depends = pacman<5.1
+ depends = pacman>=6.1
+ depends = pacman<6.2
depends = curl
depends = libnotify
depends = notification-daemon
- source = https://jjacky.com/kalu/kalu-4.2.0.tar.gz
- sha1sums = 0323a4cfcc269829641f73fd7a0c21a7619660a6
+ source = https://github.com/Thulinma/kalu/archive/refs/tags/4.5.2.tar.gz
+ md5sums = d112db6a3fffb5dffe95f4e3f4db1caf
pkgname = kalu
-
diff --git a/PKGBUILD b/PKGBUILD
index 71edfc375e55..d2dca60ea25c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
+# Maintainer: Thulinma
# Maintainer: jjacky
pkgname=kalu
-pkgver=4.2.0
+pkgver=4.5.2
pkgrel=1
pkgdesc="Upgrade notifier w/ AUR support, watched (AUR) packages, news"
-arch=('i686' 'x86_64')
-url="https://jjacky.com/kalu"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/Thulinma/kalu"
license=('GPL3+')
-depends=('dbus' 'polkit' 'gtk3' 'pacman>=5.0' 'pacman<5.1' 'curl' 'libnotify'
- 'notification-daemon')
+depends=('dbus' 'polkit' 'gtk3' 'pacman>=6.1' 'pacman<6.2' 'curl' 'libnotify' 'notification-daemon')
makedepends=('perl' 'groff')
-source=(https://jjacky.com/$pkgname/$pkgname-$pkgver.tar.gz)
+source=(https://github.com/Thulinma/kalu/archive/refs/tags/$pkgver.tar.gz)
install=kalu.install
-sha1sums=('0323a4cfcc269829641f73fd7a0c21a7619660a6')
+md5sums=('d112db6a3fffb5dffe95f4e3f4db1caf')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh
./configure --prefix=/usr
make
}
@@ -26,4 +27,3 @@ package() {
chown 0:102 "$pkgdir/usr/share/polkit-1/rules.d"
}
-# vim:set ts=2 sw=2 et: