summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16a195d01598..c9001c4e9283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = kalu-git
pkgdesc = Upgrade notifier w/ AUR support, watched (AUR) packages, news
- pkgver = 20120914
+ pkgver = 20121103
pkgrel = 1
url = https://github.com/jjk-jacky/kalu
arch = i686
arch = x86_64
license = GPL3+
+ makedepends = perl
+ makedepends = groff
makedepends = git
makedepends = autoconf
depends = dbus
@@ -16,7 +18,6 @@ pkgbase = kalu-git
depends = curl
depends = libnotify
depends = notification-daemon
- depends = xdg-utils
provides = kalu
conflicts = kalu
diff --git a/PKGBUILD b/PKGBUILD
index c9959b7c3156..7072861a814c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: jjacky
pkgname=kalu-git
-pkgver=20120914
+pkgver=20121103
pkgrel=1
pkgdesc="Upgrade notifier w/ AUR support, watched (AUR) packages, news"
arch=('i686' 'x86_64')
url="https://github.com/jjk-jacky/kalu"
license=('GPL3+')
-depends=('dbus' 'polkit' 'gtk3' 'pacman>=4.0.1' 'pacman<4.1' 'curl' 'libnotify' 'notification-daemon' 'xdg-utils')
-makedepends=('git' 'autoconf')
+depends=('dbus' 'polkit' 'gtk3' 'pacman>=4.0.1' 'pacman<4.1' 'curl' 'libnotify' 'notification-daemon')
+makedepends=('perl' 'groff' 'git' 'autoconf')
provides=('kalu')
conflicts=('kalu')
-_gitroot=https://github.com/jjk-jacky/kalu
+_gitroot=https://github.com/jjk-jacky/kalu.git
_gitname=kalu
build() {
@@ -35,7 +35,7 @@ build() {
#
# BUILD HERE
#
- autoreconf -i
+ ./autogen.sh
./configure --prefix=/usr --enable-git-version
make
}