summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--katawa-shoujo2
-rw-r--r--katawa-shoujo.desktop9
-rw-r--r--katawa-shoujo.install11
-rw-r--r--katawa-shoujo.pngbin0 -> 57929 bytes
6 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73b5b4a02d6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = katawa-shoujo
+ pkgdesc = Ren'Py game Katawa Shoujo (only data file, need renpy installed)
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://katawa-shoujo.com/
+ install = katawa-shoujo.install
+ arch = any
+ license = CCPL:BY-NC-ND
+ depends = renpy
+ provides = katawa-shoujo
+ conflicts = katawa-shoujo
+ source = [4ls]_katawa_shoujo_1.3.1-[linux-x86][18161880].tar.bz2::http://dl.katawa-shoujo.com/gold_1.3.1/%5b4ls%5d_katawa_shoujo_1.3.1-%5blinux-x86%5d%5b18161880%5d.tar.bz2
+ source = katawa-shoujo
+ source = katawa-shoujo.desktop
+ source = katawa-shoujo.png
+ md5sums = 8511b385c755e810893d05e5264b363d
+ md5sums = 88bb1f3a99762f8ea1e4fd3b7effec23
+ md5sums = 52da5f2a8365a9b88d65fad1301e439b
+ md5sums = 6d70e339e33d7c13a8ab03a5d3498c4f
+
+pkgname = katawa-shoujo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bbb7389fcc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Based on katawa-shoujo PKGBUILD written by Anton Larionov <diffident dot cat at gmail dot com>
+# Maintainer: Cravix < dr dot neemous at gmail dot com >
+
+pkgname=katawa-shoujo
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Ren'Py game Katawa Shoujo (only data file, need renpy installed)"
+arch=('any')
+url='http://katawa-shoujo.com/'
+license=('CCPL:BY-NC-ND')
+depends=('renpy')
+provides=('katawa-shoujo')
+conflicts=('katawa-shoujo')
+install="${pkgname}.install"
+source=("[4ls]_katawa_shoujo_${pkgver}-[linux-x86][18161880].tar.bz2::http://dl.katawa-shoujo.com/gold_${pkgver}/%5b4ls%5d_katawa_shoujo_${pkgver}-%5blinux-x86%5d%5b18161880%5d.tar.bz2"
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+
+md5sums=('8511b385c755e810893d05e5264b363d'
+ '88bb1f3a99762f8ea1e4fd3b7effec23'
+ '52da5f2a8365a9b88d65fad1301e439b'
+ '6d70e339e33d7c13a8ab03a5d3498c4f')
+
+package() {
+ # copy main files
+ cd "${srcdir}/Katawa Shoujo-${pkgver}-linux/"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ cp -r game "${pkgdir}/usr/share/${pkgname}"
+
+ # copy game manual
+ install -D -m644 'Game Manual.pdf' "${pkgdir}/usr/share/doc/${pkgname}/gamemanual.pdf"
+
+ # copy license
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # copy bash script
+ install -D -m755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # install desktop entry file
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/katawa-shoujo b/katawa-shoujo
new file mode 100644
index 000000000000..a7849663d6fb
--- /dev/null
+++ b/katawa-shoujo
@@ -0,0 +1,2 @@
+#! /usr/bin/env sh
+renpy /usr/share/katawa-shoujo/
diff --git a/katawa-shoujo.desktop b/katawa-shoujo.desktop
new file mode 100644
index 000000000000..a522db0da191
--- /dev/null
+++ b/katawa-shoujo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Katawa Shoujo
+Comment=Bishoujo-style visual novel game that tells a story of a young man and five other girls suffering with varying disabilities
+Icon=katawa-shoujo.png
+Exec=/usr/bin/katawa-shoujo
+Terminal=false
+Categories=Application;Game;
diff --git a/katawa-shoujo.install b/katawa-shoujo.install
new file mode 100644
index 000000000000..266bcf1db5cd
--- /dev/null
+++ b/katawa-shoujo.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo "==> You can find game manual at"
+ echo "==> /usr/share/doc/katawa-shoujo/gamemanual.pdf"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}
+
diff --git a/katawa-shoujo.png b/katawa-shoujo.png
new file mode 100644
index 000000000000..1f96fb95d64e
--- /dev/null
+++ b/katawa-shoujo.png
Binary files differ