summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--kawaii-player.install14
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56c65437eaf7..c14e4ebe5255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = kawaii-player
pkgdesc = A powerful frontend for MPV with media server and torrent streaming capabilities
- pkgver = 2.9.0
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/kanishka-linux/kawaii-player
+ install = kawaii-player.install
arch = any
license = GPL3
makedepends = git
@@ -21,11 +22,11 @@ pkgbase = kawaii-player
depends = python-pyqt5
depends = python-pytaglib
depends = qt5-webengine
- depends = sqlite3
+ depends = sqlite
depends = wget
depends = youtube-dl
- source = https://github.com/kanishka-linux/kawaii-player/releases/download/v2.9.0-0/kawaii-player-2.9.0-0.tar.bz2
- md5sums = b469c0deb51ecf1322f2a7eb8c5cd3bd
+ source = https://github.com/kanishka-linux/kawaii-player/releases/download/v3.1.1-0/kawaii-player-3.1.1-0.tar.bz2
+ md5sums = 695dcb749f56541eda98ee249d4378ba
pkgname = kawaii-player
diff --git a/PKGBUILD b/PKGBUILD
index b904b3eac3b4..8cb6123c260f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nocifer <apmihalopoulos at gmail dot com>
pkgname=kawaii-player
_pkgname=kawaii_player
-pkgver=2.9.0
+pkgver=3.1.1
pkgrel=1
_pkgrel=0
pkgdesc="A powerful frontend for MPV with media server and torrent streaming capabilities"
@@ -9,10 +9,11 @@ arch=(any)
url="https://github.com/kanishka-linux/kawaii-player"
license=('GPL3')
depends=('curl' 'ffmpegthumbnailer' 'libnotify' 'libtorrent-rasterbar' 'mpv' 'python' 'python-beautifulsoup4' 'python-dbus' 'python-lxml'
- 'python-mutagen' 'python-pillow' 'python-pycurl' 'python-pyqt5' 'python-pytaglib' 'qt5-webengine' 'sqlite3' 'wget' 'youtube-dl')
+ 'python-mutagen' 'python-pillow' 'python-pycurl' 'python-pyqt5' 'python-pytaglib' 'qt5-webengine' 'sqlite' 'wget' 'youtube-dl')
makedepends=('git')
source=("https://github.com/kanishka-linux/${pkgname}/releases/download/v${pkgver}-${_pkgrel}/${pkgname}-${pkgver}-${_pkgrel}.tar.bz2")
-md5sums=('b469c0deb51ecf1322f2a7eb8c5cd3bd')
+install=kawaii-player.install
+md5sums=('695dcb749f56541eda98ee249d4378ba')
package() {
_app_dir="${srcdir}/${pkgname}-${pkgver}-${_pkgrel}/${_pkgname}"
diff --git a/kawaii-player.install b/kawaii-player.install
new file mode 100644
index 000000000000..b291bee44405
--- /dev/null
+++ b/kawaii-player.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo
+ echo "If you are upgrading from Kawaii Player v2.9 or earlier, you are advised"
+ echo "to backup and then remove the following configuration files:"
+ echo "~/.config/kawaii-player/other_options.txt"
+ echo "~/.config/kawaii-player/config.txt"
+ echo "~/.config/kawaii-player/src/input.conf"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}
+