summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--configparser_api_changes.patch21
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85ab502ce7fa..fd5792568c95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Jan 6 21:15:33 UTC 2016
pkgbase = kazam
pkgdesc = A screencasting program with design in mind
pkgver = 1.4.5
- pkgrel = 3
+ pkgrel = 4
url = https://launchpad.net/kazam
install = kazam.install
arch = any
@@ -28,8 +30,10 @@ pkgbase = kazam
conflicts = kazam-stable-bzr
source = https://launchpad.net/kazam/stable/1.4.5/+download/kazam-1.4.5.tar.gz
source = version.patch
+ source = configparser_api_changes.patch
md5sums = 522ac80fef7123875271b30298ed6877
md5sums = 847ae2478ae5e35f6e1af49aa9fb3fa9
+ md5sums = 8e751e821558c989ac02ef687a7b7339
pkgname = kazam
diff --git a/PKGBUILD b/PKGBUILD
index 4af56c632ece..c285121cda2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=kazam
pkgver=1.4.5
-pkgrel=3
+pkgrel=4
pkgdesc="A screencasting program with design in mind"
arch=('any')
url="https://launchpad.net/kazam"
@@ -13,13 +13,16 @@ optdepends=('libkeybinder3: hotkeys support' 'libappindicator3: indicator on Uni
conflicts=('kazam-bzr' 'kazam-stable-bzr')
install=kazam.install
source=("https://launchpad.net/${pkgname}/stable/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
- 'version.patch')
+ 'version.patch'
+ 'configparser_api_changes.patch')
md5sums=('522ac80fef7123875271b30298ed6877'
- '847ae2478ae5e35f6e1af49aa9fb3fa9')
+ '847ae2478ae5e35f6e1af49aa9fb3fa9'
+ '8e751e821558c989ac02ef687a7b7339')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < "${srcdir}/version.patch"
+ patch -p1 < "${srcdir}/configparser_api_changes.patch"
}
package() {
@@ -28,3 +31,4 @@ package() {
}
+
diff --git a/configparser_api_changes.patch b/configparser_api_changes.patch
new file mode 100644
index 000000000000..04b46d9b8f21
--- /dev/null
+++ b/configparser_api_changes.patch
@@ -0,0 +1,21 @@
+From: Andrew Starr-Bochicchio <asb@debian.org>
+Subject: Update for changes in ConfigParser api.
+Bug: https://bugs.launchpad.net/kazam/+bug/1500083
+
+Index: kazam/kazam/backend/config.py
+===================================================================
+--- kazam.orig/kazam/backend/config.py 2013-03-13 20:25:20.917993000 -0400
++++ kazam/kazam/backend/config.py 2015-10-12 21:25:30.355157111 -0400
+@@ -98,9 +98,10 @@
+ if d_key == key:
+ return d_section["keys"][key]
+
+- def get(self, section, key):
++ def get(self, section, key, raw=True, fallback=None):
+ try:
+- return ConfigParser.get(self, section, key)
++ return super(KazamConfig, self).get(section,
++ key, raw=True, fallback=fallback)
+ except NoSectionError:
+ default = self.find_default(section, key)
+ self.set(section, key, default)