summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--fix-kutil_openlog.patch24
3 files changed, 7 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba917a4322b..4a3a3e7545be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = kcgi
pkgdesc = Minimal CGI and FastCGI library
- pkgver = 0.9.1
+ pkgver = 0.9.4
pkgrel = 1
url = http://kristaps.bsd.lv/kcgi/
arch = i686
arch = x86_64
license = custom
depends = glibc
- source = https://kristaps.bsd.lv/kcgi/snapshots/kcgi-0.9.1.tgz
- source = fix-kutil_openlog.patch
+ depends = libbsd
+ source = https://kristaps.bsd.lv/kcgi/snapshots/kcgi-0.9.4.tgz
source = LICENSE
- sha512sums = 4d6f823fa4cbe47f9806ea70978e23cef6155c7f961ea9968083d6a021dc31b2386a23e9681cf60947f2caf1f9300e9f0c4ad1baf032f9080140d21d67ac2fe0
- sha512sums = c4bc67df753211e0f7c7e0296dfafafa011a50e08125e779ef88bcd8517e07406d78de9bf260fa503576eeae0e98e4648b475a4a8e9a80737f5ac059d42096f5
+ sha512sums = 6877afb9ebb7a068b4d88c6aa9dbc574674c818a1f9ecba6e49369c8f663fc7e67b5ec756733b8f39b44faee2e10ef92f3e886226b5fcba46e64fe213e1b203e
sha512sums = b040c157fe8b95a41a0375d2cd3cc4e6406a988ed5f337b0c6dd15f1ea08344196018a5c2353c2acfbde7858ca5e0f2bf00d1cc4890661effadf39e239a95520
pkgname = kcgi
diff --git a/PKGBUILD b/PKGBUILD
index 7f6bdbe6ff8e..08d136cd3c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,16 @@
# Maintainer: Wilhelm Schuster <wilhelm [aT] wilhelm [.] re>
pkgname=kcgi
-pkgver=0.9.1
+pkgver=0.9.4
pkgrel=1
pkgdesc="Minimal CGI and FastCGI library"
arch=('i686' 'x86_64')
url="http://kristaps.bsd.lv/kcgi/"
license=('custom')
-depends=('glibc')
+depends=('glibc' 'libbsd')
source=("https://kristaps.bsd.lv/kcgi/snapshots/$pkgname-$pkgver.tgz"
- "fix-kutil_openlog.patch"
"LICENSE")
-sha512sums=('4d6f823fa4cbe47f9806ea70978e23cef6155c7f961ea9968083d6a021dc31b2386a23e9681cf60947f2caf1f9300e9f0c4ad1baf032f9080140d21d67ac2fe0'
- 'c4bc67df753211e0f7c7e0296dfafafa011a50e08125e779ef88bcd8517e07406d78de9bf260fa503576eeae0e98e4648b475a4a8e9a80737f5ac059d42096f5'
+sha512sums=('6877afb9ebb7a068b4d88c6aa9dbc574674c818a1f9ecba6e49369c8f663fc7e67b5ec756733b8f39b44faee2e10ef92f3e886226b5fcba46e64fe213e1b203e'
'b040c157fe8b95a41a0375d2cd3cc4e6406a988ed5f337b0c6dd15f1ea08344196018a5c2353c2acfbde7858ca5e0f2bf00d1cc4890661effadf39e239a95520')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "${srcdir}/fix-kutil_openlog.patch"
-}
-
build() {
cd $pkgname-$pkgver
diff --git a/fix-kutil_openlog.patch b/fix-kutil_openlog.patch
deleted file mode 100644
index e9b23749d911..000000000000
--- a/fix-kutil_openlog.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From da456618e693be27ba6ddf56cef579895fa1d9c5 Mon Sep 17 00:00:00 2001
-From: kristaps <>
-Date: Sun, 30 Oct 2016 19:25:17 +0000
-Subject: [PATCH] Portability: on Linux, setlinebuf doesn't wrap directly
- around setvbuf. Noted on https://github.com/kristapsdz/kcgi/pull/10 --
- thanks!
-
----
- logging.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/logging.c b/logging.c
-index f06e7a6..831b935 100644
---- a/logging.c
-+++ b/logging.c
-@@ -103,7 +103,7 @@ kutil_openlog(const char *file)
-
- if (NULL != file && NULL == freopen(file, "a", stderr))
- return(0);
-- return(EOF != setlinebuf(stderr));
-+ return(EOF != setvbuf(stderr, NULL, _IOLBF, 0));
- }
-
- void