summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--set_cmake_min_req.patch35
3 files changed, 49 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5acc518e693..00d548df9362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kcm-wacomtablet
pkgdesc = KDE GUI for the Wacom Linux Drivers
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://kde-apps.org/content/show.php/wacom+tablet?content=114856
arch = i686
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = kcm-wacomtablet
depends = kdebase-workspace
depends = xf86-input-wacom
source = http://kde-apps.org/CONTENT/content-files/114856-wacomtablet-2.1.0.tar.xz
+ source = set_cmake_min_req.patch
md5sums = fb2f3eefa6ac7e3c7b07a42ea4f6624c
+ md5sums = 74f33a2c84571709b6a2c703826ab493
pkgname = kcm-wacomtablet
diff --git a/PKGBUILD b/PKGBUILD
index 5d8d3c928fd4..1ed3a763e025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,23 @@
# Contributor: Dylon Edwards <deltaecho@archlinux.us>
pkgname=kcm-wacomtablet
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="KDE GUI for the Wacom Linux Drivers"
arch=('i686' 'x86_64')
url="http://kde-apps.org/content/show.php/wacom+tablet?content=114856"
license=('GPL2')
depends=('kdebase-workspace' 'xf86-input-wacom')
makedepends=('cmake' 'automoc4')
-source=("http://kde-apps.org/CONTENT/content-files/114856-wacomtablet-${pkgver}.tar.xz")
-md5sums=('fb2f3eefa6ac7e3c7b07a42ea4f6624c')
+source=("http://kde-apps.org/CONTENT/content-files/114856-wacomtablet-${pkgver}.tar.xz" \
+ "set_cmake_min_req.patch")
+md5sums=('fb2f3eefa6ac7e3c7b07a42ea4f6624c'
+ '74f33a2c84571709b6a2c703826ab493')
+
+prepare() {
+ cd "$srcdir/wacomtablet-$pkgver"
+
+ patch -Np1 < "$srcdir/set_cmake_min_req.patch"
+}
build() {
cd "$srcdir/wacomtablet-$pkgver"
diff --git a/set_cmake_min_req.patch b/set_cmake_min_req.patch
new file mode 100644
index 000000000000..7e6fa141822a
--- /dev/null
+++ b/set_cmake_min_req.patch
@@ -0,0 +1,35 @@
+From: David Faure <faure@kde.org>
+Date: Mon, 27 Jul 2015 20:09:38 +0000
+Subject: set cmake_min_req to enable newer policies; fix duplicated target name
+X-Git-Url: http://quickgit.kde.org/?p=wacomtablet.git&a=commitdiff&h=9b641e5526b8bb5e089d344f4993f1ff77a0a4fe
+---
+set cmake_min_req to enable newer policies; fix duplicated target name
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required(VERSION 2.6)
++cmake_minimum_required(VERSION 2.8.9)
+
+ project(wacomtablet)
+
+
+--- a/autotests/kded/xinputadaptor/CMakeLists.txt
++++ b/autotests/kded/xinputadaptor/CMakeLists.txt
+@@ -1,11 +1,11 @@
+
+
+-kde4_add_unit_test(KDED.XsetWacomAdaptor
++kde4_add_unit_test(KDED.XinputWacomAdaptor
+ testxinputadaptor.cpp
+ ../tabletdependenttest.cpp
+ )
+
+-target_link_libraries(KDED.XsetWacomAdaptor
++target_link_libraries(KDED.XinputWacomAdaptor
+
+ # include static libs
+ wacom_common
+