summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
-rw-r--r--prefix.patch11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef27443069cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = kcoreaddons-blucrystal
+ pkgdesc = Addons to QtCore (with the metric binary dialect, so sizes will be measured in KB/MB/GB/etc instead of KiB/MiB/GiB/etc)
+ pkgver = 5.75.0
+ pkgrel = 1
+ url = https://community.kde.org/Frameworks
+ arch = x86_64
+ groups = kf5
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = qt5-doc
+ makedepends = qt5-doc
+ makedepends = clang
+ makedepends = python-pyqt5
+ makedepends = doxygen
+ makedepends = sip
+ depends = qt5-base
+ optdepends = python-pyqt5: for the Python bindings
+ provides = kcoreaddons
+ conflicts = kcoreaddons
+ source = https://download.kde.org/stable/frameworks/5.75/kcoreaddons-5.75.0.tar.xz
+ source = https://download.kde.org/stable/frameworks/5.75/kcoreaddons-5.75.0.tar.xz.sig
+ source = prefix.patch
+ validpgpkeys = 53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB
+ sha256sums = 9ca2cf82ddc12e27ff73aaefdf616c3eb6552a3a5531f014b5bf52a34a4c73f9
+ sha256sums = SKIP
+ sha256sums = 85315f2bea9e2bf31ebe6c8edb57731672cf8471713b7d7757d4a4d115b6d92f
+
+pkgname = kcoreaddons-blucrystal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae7ba7d1dc5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Dynakarp <dynacorp@protonmail.com>
+
+_pkgname=kcoreaddons
+pkgname=kcoreaddons-blucrystal
+pkgver=5.75.0
+pkgrel=1
+pkgdesc='Addons to QtCore (with the metric binary dialect, so sizes will be measured in KB/MB/GB/etc instead of KiB/MiB/GiB/etc)'
+arch=(x86_64)
+url='https://community.kde.org/Frameworks'
+license=(LGPL)
+depends=(qt5-base)
+makedepends=(extra-cmake-modules qt5-tools qt5-doc qt5-doc clang python-pyqt5 doxygen sip)
+optdepends=('python-pyqt5: for the Python bindings')
+groups=(kf5)
+provides=(kcoreaddons)
+conflicts=(kcoreaddons)
+source=("https://download.kde.org/stable/frameworks/${pkgver%.*}/$_pkgname-$pkgver.tar.xz"{,.sig}
+ "prefix.patch")
+sha256sums=('9ca2cf82ddc12e27ff73aaefdf616c3eb6552a3a5531f014b5bf52a34a4c73f9'
+ 'SKIP'
+ '85315f2bea9e2bf31ebe6c8edb57731672cf8471713b7d7757d4a4d115b6d92f')
+validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+}
+
+build() {
+ cmake -B build -S $_pkgname-$pkgver \
+ -D_KDE4_DEFAULT_HOME_POSTFIX=4 \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
diff --git a/prefix.patch b/prefix.patch
new file mode 100644
index 000000000000..92dd931c6454
--- /dev/null
+++ b/prefix.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/util/kformat.h 2020-10-08 11:31:52.259466585 -0500
++++ b/src/lib/util/kformat.h 2020-10-08 11:32:23.409493135 -0500
+@@ -169,7 +169,7 @@
+ * @see formatByteSize
+ */
+ enum BinaryUnitDialect {
+- DefaultBinaryDialect = -1, ///< Used if no specific preference
++ DefaultBinaryDialect = -3, ///< Used if no specific preference
+ IECBinaryDialect, ///< KiB, MiB, etc. 2^(10*n)
+ JEDECBinaryDialect, ///< KB, MB, etc. 2^(10*n)
+ MetricBinaryDialect, ///< SI Units, kB, MB, etc. 10^(3*n)