summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3124a283a3aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kde-fcstd-thumbnailer-git
+ pkgdesc = FreeCAD Thumbnail Creator.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/StefanHamminga/kde-fcstd-thumbnailer
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = kio5
+ provides = kde-fcstd-thumbnailer-git=2.0.0
+ conflicts = kde-fcstd-thumbnailer-git
+ replaces = kde-fcstd-thumbnailer-git
+ source = kde-fcstd-thumbnailer-git::git+https://github.com/StefanHamminga/kde-fcstd-thumbnailer.git
+ sha256sums = SKIP
+
+pkgname = kde-fcstd-thumbnailer-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..821df2f9b99a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=kde-fcstd-thumbnailer-git
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='FreeCAD Thumbnail Creator.'
+arch=('i686' 'x86_64')
+url='https://github.com/StefanHamminga/kde-fcstd-thumbnailer'
+license=('GPL3')
+
+depends=('qt5-base' 'kio5')
+makedepends=('cmake' 'extra-cmake-modules' 'qt5-tools')
+provides=(${pkgname}=${pkgver})
+conflicts=(${pkgname})
+replaces=(${pkgname})
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}/
+ cmake -B build -DCMAKE_PREFIX_PATH:PATH=/usr/lib/cmake/Qt5
+ cmake --build build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/
+ install -Dm644 ./build/fcstdthumbnailer.so ${pkgdir}/usr/lib/qt/plugins/fcstdthumbnailer.so
+ install -Dm644 ./src/fcstdthumbnailer.desktop ${pkgdir}/usr/share/kservices5/fcstdthumbnailer.desktop
+}