summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d144da833927
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Nov 15 14:24:36 UTC 2016
+pkgbase = kde1-kdegames
+ pkgdesc = Historical copy of the gaming applications module of KDE 1, adapted to compile on modern systems (circa. 2016)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/KDE/kde1-kdegames
+ arch = i686
+ arch = x86_64
+ groups = kde1
+ license = GPL2
+ makedepends = cmake
+ depends = qt1
+ depends = kde1-kdelibs
+ source = https://github.com/KDE/kde1-kdegames/archive/0c70bf0d7c9ace37095e4a02bed921f4e301f17a.zip
+ sha256sums = f6b4006f83e282c581ae1c6033455d68138046967644bfb92764fc5af8f64164
+
+pkgname = kde1-kdegames
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497615efe62d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=kde1-kdegames
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Historical copy of the gaming applications module of KDE 1, adapted to compile on modern systems (circa. 2016)"
+arch=('i686' 'x86_64')
+url="https://github.com/KDE/kde1-kdegames"
+license=("GPL2")
+groups=("kde1")
+depends=("qt1" "kde1-kdelibs")
+makedepends=("cmake")
+_commit="0c70bf0d7c9ace37095e4a02bed921f4e301f17a"
+source=("https://github.com/KDE/$pkgname/archive/$_commit.zip")
+sha256sums=('f6b4006f83e282c581ae1c6033455d68138046967644bfb92764fc5af8f64164')
+
+#prepare() {
+# cd $srcdir/$pkgname-$_commit
+# patch -p1 kfm/pics/CMakeLists.txt < $srcdir/kfm_CMakeLists.patch
+#}
+
+build() {
+ cd $srcdir/$pkgname-$_commit
+ #cd $srcdir/$pkgname
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_LIBRARY_PATH='/opt/kde1/lib'
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$_commit
+ #cd $srcdir/$pkgname
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd ..
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+
+# vim:set ts=2 sw=2 et: