summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD70
-rw-r--r--kdebase-runtime-no-html-thumbnails.patch21
-rw-r--r--kdebase-runtime-no-kdewebkit.patch49
4 files changed, 181 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22ab671ae96d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = kdebase-runtime
+ pkgdesc = Plugins and applications necessary for the running of KDE applications
+ pkgver = 17.08.3
+ pkgrel = 4
+ url = https://www.kde.org/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = pkg-config
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = doxygen
+ makedepends = networkmanager
+ makedepends = boost
+ depends = kdelibs
+ depends = smbclient
+ depends = libssh
+ depends = libcanberra
+ depends = oxygen-icons
+ depends = xorg-xauth
+ depends = libwebp
+ depends = exiv2
+ depends = gpgme
+ optdepends = drkonqi: crash report tool
+ optdepends = khelpcenter: to display applications documentation
+ provides = notification-daemon
+ conflicts = kdesu4
+ replaces = kdesu4
+ source = https://download.kde.org/Attic/applications/17.08.3/src/kde-runtime-17.08.3.tar.xz
+ source = https://download.kde.org/Attic/applications/17.08.3/src/kde-runtime-17.08.3.tar.xz.sig
+ source = kdebase-runtime-no-html-thumbnails.patch
+ source = kdebase-runtime-no-kdewebkit.patch
+ validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
+ validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
+ sha256sums = 682c18afb11cda41288c4508831cb59797417b9d81ea916e0e99722ebe9bce96
+ sha256sums = SKIP
+ sha256sums = 5ce434f25759215ed2b6f71ec82a9118ee76e7428ef1af8a5495133a76c9c2df
+ sha256sums = 93d5ddf78c784b3d79486813bdfb43debba271b389bfc46ca79aabdb0bca14db
+
+pkgname = kdebase-runtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c642a511f3e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# $Id: PKGBUILD 317536 2018-02-26 03:06:37Z arojas $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=kdebase-runtime
+pkgver=17.08.3
+pkgrel=4
+pkgdesc="Plugins and applications necessary for the running of KDE applications"
+arch=('x86_64')
+url='https://www.kde.org/'
+license=('GPL' 'LGPL')
+makedepends=('pkg-config' 'cmake' 'automoc4' 'doxygen' 'networkmanager' 'boost')
+depends=('kdelibs' 'smbclient' 'libssh' 'libcanberra' 'oxygen-icons' 'xorg-xauth' 'libwebp' 'exiv2' 'gpgme')
+optdepends=('drkonqi: crash report tool' 'khelpcenter: to display applications documentation')
+provides=(notification-daemon)
+conflicts=(kdesu4)
+replaces=(kdesu4)
+source=("https://download.kde.org/Attic/applications/$pkgver/src/kde-runtime-$pkgver.tar.xz"{,.sig}
+ kdebase-runtime-no-html-thumbnails.patch kdebase-runtime-no-kdewebkit.patch)
+sha256sums=('682c18afb11cda41288c4508831cb59797417b9d81ea916e0e99722ebe9bce96'
+ 'SKIP'
+ '5ce434f25759215ed2b6f71ec82a9118ee76e7428ef1af8a5495133a76c9c2df'
+ '93d5ddf78c784b3d79486813bdfb43debba271b389bfc46ca79aabdb0bca14db')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
+
+prepare() {
+ mkdir -p build
+
+# Don't link to kactivities
+ sed -e '/plasmaextracomponents/d' -i kde-runtime-$pkgver/plasma/declarativeimports/CMakeLists.txt
+# Drop HTML thumbnailer, uses insecure QtWebKit
+ cd kde-runtime-$pkgver
+ patch -p1 -i ../kdebase-runtime-no-html-thumbnails.patch
+ patch -p1 -i ../kdebase-runtime-no-kdewebkit.patch
+}
+
+build() {
+ cd build
+ cmake ../kde-runtime-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE4_BUILD_TESTS=OFF \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QNtrack=OFF \
+ -DSAMBA_INCLUDE_DIR=/usr/include/samba-4.0 \
+ -DWITH_NepomukCore=OFF \
+ -DBUILD_khelpcenter=OFF \
+ -DBUILD_kglobalaccel=OFF \
+ -DBUILD_kuiserver=OFF \
+ -DBUILD_drkonqi=OFF \
+ -DBUILD_doc=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/usr/share/icons/hicolor/index.theme
+ ln -s /usr/lib/kde4/libexec/kdesu "$pkgdir"/usr/bin/kdesu4
+
+# Use KF5 drkonqi
+ ln -s /usr/lib/drkonqi "$pkgdir"/usr/lib/kde4/libexec/
+
+# FS#36668
+ chown :nobody "$pkgdir"/usr/lib/kde4/libexec/kdesud
+ chmod g+s "$pkgdir"/usr/lib/kde4/libexec/kdesud
+}
diff --git a/kdebase-runtime-no-html-thumbnails.patch b/kdebase-runtime-no-html-thumbnails.patch
new file mode 100644
index 000000000000..7e8cf076fdf8
--- /dev/null
+++ b/kdebase-runtime-no-html-thumbnails.patch
@@ -0,0 +1,21 @@
+--- kde-runtime-16.12.1/kioslave/thumbnail/CMakeLists.txt.0 2017-01-19 12:11:22.764891155 +0000
++++ kde-runtime-16.12.1/kioslave/thumbnail/CMakeLists.txt 2017-01-19 12:11:40.741524858 +0000
+@@ -89,18 +89,6 @@
+
+ ########### next target ###############
+
+-if(NOT WINCE)
+-set(htmlthumbnail_PART_SRCS htmlcreator.cpp)
+-
+-kde4_add_plugin(htmlthumbnail ${htmlthumbnail_PART_SRCS})
+-
+-target_link_libraries(htmlthumbnail ${KDE4_KDEWEBKIT_LIBS})
+-
+-install(TARGETS htmlthumbnail DESTINATION ${PLUGIN_INSTALL_DIR})
+-endif(NOT WINCE)
+-
+-########### next target ###############
+-
+ if(NOT WIN32)
+ set(djvuthumbnail_PART_SRCS djvucreator.cpp)
+
diff --git a/kdebase-runtime-no-kdewebkit.patch b/kdebase-runtime-no-kdewebkit.patch
new file mode 100644
index 000000000000..59c4e2708d6e
--- /dev/null
+++ b/kdebase-runtime-no-kdewebkit.patch
@@ -0,0 +1,49 @@
+diff --git a/plasma/declarativeimports/graphicswidgets/graphicswidgetsbindingsplugin.cpp b/plasma/declarativeimports/graphicswidgets/graphicswidgetsbindingsplugin.cpp
+index 72bf7f828f..14a2905f97 100644
+--- a/plasma/declarativeimports/graphicswidgets/graphicswidgetsbindingsplugin.cpp
++++ b/plasma/declarativeimports/graphicswidgets/graphicswidgetsbindingsplugin.cpp
+@@ -47,7 +47,6 @@
+ #include <Plasma/ToolButton>
+ #include <Plasma/TreeView>
+ #include <Plasma/VideoWidget>
+-#include <Plasma/WebView>
+
+ #include "declarativetabbar.h"
+
+@@ -99,7 +98,6 @@ void GraphicsWidgetsBindingsPlugin::registerTypes(const char *uri)
+ qmlRegisterType<Plasma::ToolButton>(uri, 0, 1, "ToolButton");
+ qmlRegisterType<Plasma::TreeView>(uri, 0, 1, "TreeView");
+ qmlRegisterType<Plasma::VideoWidget>(uri, 0, 1, "VideoWidget");
+- qmlRegisterType<Plasma::WebView>(uri, 0, 1, "WebView");
+ }
+
+
+diff --git a/plasma/scriptengines/javascript/simplebindings/uiloader.cpp b/plasma/scriptengines/javascript/simplebindings/uiloader.cpp
+index f13ad5cef0..fe85910ccb 100644
+--- a/plasma/scriptengines/javascript/simplebindings/uiloader.cpp
++++ b/plasma/scriptengines/javascript/simplebindings/uiloader.cpp
+@@ -49,7 +49,6 @@
+ #include <Plasma/TextEdit>
+ #include <Plasma/ToolButton>
+ #include <Plasma/TreeView>
+-#include <Plasma/WebView>
+ #include <Plasma/VideoWidget>
+
+
+@@ -78,7 +77,6 @@ QGraphicsWidget *createTextEdit(QGraphicsWidget *parent) { return new Plasma::Te
+ QGraphicsWidget *createToolButton(QGraphicsWidget *parent) { return new Plasma::ToolButton(parent); }
+ QGraphicsWidget *createTreeView(QGraphicsWidget *parent) { return new Plasma::TreeView(parent); }
+ QGraphicsWidget *createVideoWidget(QGraphicsWidget *parent) { return new Plasma::VideoWidget(parent); }
+-QGraphicsWidget *createWebView(QGraphicsWidget *parent) { return new Plasma::WebView(parent); }
+ QGraphicsWidget *createGraphicsWidget(QGraphicsWidget *parent) { return new QGraphicsWidget(parent); }
+
+ UiLoader::UiLoader()
+@@ -108,8 +106,6 @@ UiLoader::UiLoader()
+ m_widgetCtors.insert("ToolButton", createToolButton);
+ m_widgetCtors.insert("TreeView", createTreeView);
+ m_widgetCtors.insert("VideoWidget", createVideoWidget);
+- m_widgetCtors.insert("WebView", createWebView);
+- m_widgetCtors.insert("GraphicsWidget", createWebView);
+ }
+
+ UiLoader::~UiLoader()