summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a62f7e995c1b..0e00a002693a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,31 @@
pkgbase = kdialog-git
pkgdesc = A utility for displaying dialog boxes from shell scripts
- pkgver = 21.03.70_r1167.gd1a5a9518
+ pkgver = 24.04.70_r1478.g33d49400b
pkgrel = 1
url = https://www.kde.org/
arch = x86_64
groups = kde-applications-git
groups = kde-utilities-git
- license = LGPL
+ license = LGPL-2.0-or-later
makedepends = git
makedepends = extra-cmake-modules-git
+ depends = gcc-libs
+ depends = glibc
+ depends = kconfig-git
+ depends = kcoreaddons-git
+ depends = kdbusaddons-git
+ depends = kguiaddons-git
+ depends = ki18n-git
+ depends = kiconthemes-git
depends = kio-git
+ depends = ktextwidgets-git
+ depends = kwidgetsaddons-git
+ depends = kwindowsystem-git
+ depends = libx11
+ depends = qt6-base
provides = kdialog
conflicts = kdialog
source = git+https://github.com/KDE/kdialog.git
sha256sums = SKIP
pkgname = kdialog-git
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 05c6d4d4c97b..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!.SRCINFO
-!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8cb09908260f..8f1139bec681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Merged with official ABS kdialog PKGBUILD by João, 2021/02/01 (all respective contributors apply herein)
-# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
# Contributor: Antonio Rojas <arojas@archlinux,org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kdialog-git
-pkgver=21.03.70_r1167.gd1a5a9518
+pkgver=24.04.70_r1478.g33d49400b
pkgrel=1
pkgdesc="A utility for displaying dialog boxes from shell scripts"
arch=($CARCH)
url="https://www.kde.org/"
-license=(LGPL)
-depends=(kio-git)
+license=(LGPL-2.0-or-later)
+depends=(gcc-libs glibc kconfig-git kcoreaddons-git kdbusaddons-git kguiaddons-git ki18n-git kiconthemes-git kio-git ktextwidgets-git kwidgetsaddons-git kwindowsystem-git libx11 qt6-base)
makedepends=(git extra-cmake-modules-git)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
@@ -20,14 +20,15 @@ sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _major_ver="$(grep -m1 "set *(RELEASE_SERVICE_VERSION_MAJOR" CMakeLists.txt | cut -d '"' -f2)"
- _minor_ver="$(grep -m1 "set *(RELEASE_SERVICE_VERSION_MINOR" CMakeLists.txt | cut -d '"' -f2)"
- _micro_ver="$(grep -m1 "set *(RELEASE_SERVICE_VERSION_MICRO" CMakeLists.txt | cut -d '"' -f2)"
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}