summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--qt_514_build_fix.patch23
3 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15c6ccfd63d3..ae40e7d4d747 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kdocker
pkgdesc = An application to help you dock any application into the system tray
- pkgver = 5.2
- pkgrel = 2
+ pkgver = 5.3
+ pkgrel = 1
url = https://github.com/user-none/KDocker
arch = i686
arch = x86_64
@@ -10,10 +10,8 @@ pkgbase = kdocker
depends = qt5-x11extras
depends = libxpm
depends = libxmu
- source = https://github.com/user-none/KDocker/archive/5.2.tar.gz
- source = qt_514_build_fix.patch
- sha256sums = ffcb11ac0cf50ae80a35e000b7a7470259e624511d1281579386a9cb68935cba
- sha256sums = f05d163f67dd81aa6be97e8904258c108a0dd3451b667949c9c7657f6a965f0e
+ source = https://github.com/user-none/KDocker/archive/5.3.tar.gz
+ sha256sums = c49eea33d46a626b2a59c8ddc923ce9a027f0b9bd2125f4f6c264e888997e663
pkgname = kdocker
diff --git a/PKGBUILD b/PKGBUILD
index b5af98dd45f5..dad51483f2b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,17 @@
pkgname=kdocker
-pkgver=5.2
-pkgrel=2
+pkgver=5.3
+pkgrel=1
pkgdesc="An application to help you dock any application into the system tray"
arch=('i686' 'x86_64')
url="https://github.com/user-none/KDocker"
license=('GPL2')
depends=('qt5-base' 'qt5-x11extras' 'libxpm' 'libxmu')
-source=(https://github.com/user-none/KDocker/archive/${pkgver}.tar.gz
- qt_514_build_fix.patch)
-sha256sums=('ffcb11ac0cf50ae80a35e000b7a7470259e624511d1281579386a9cb68935cba'
- 'f05d163f67dd81aa6be97e8904258c108a0dd3451b667949c9c7657f6a965f0e')
+source=(https://github.com/user-none/KDocker/archive/${pkgver}.tar.gz)
+sha256sums=('c49eea33d46a626b2a59c8ddc923ce9a027f0b9bd2125f4f6c264e888997e663')
build() {
cd "$srcdir/KDocker-$pkgver"
- patch --forward --strip=1 --input="$srcdir/qt_514_build_fix.patch" src/trayitem.h
-
qmake-qt5
make
}
diff --git a/qt_514_build_fix.patch b/qt_514_build_fix.patch
deleted file mode 100644
index 7a73aa4dcdeb..000000000000
--- a/qt_514_build_fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- trayitem.h.old 2018-07-25 16:26:43.000000000 -0400
-+++ trayitem.h 2020-01-22 11:02:25.406496065 -0500
-@@ -21,6 +21,9 @@
- #ifndef _TRAYITEM_H
- #define _TRAYITEM_H
-
-+#pragma push_macro("None")
-+#undef None
-+
- #include <QAction>
- #include <QEvent>
- #include <QIcon>
-@@ -32,6 +35,10 @@
-
- #include "xlibutil.h"
-
-+#ifndef None
-+#pragma pop_macro("None")
-+#endif
-+
- #define DEFAULT_CustomIcon QString()
- #define DEFAULT_BalloonTimeout 4000 // 4 seconds
- #define DEFAULT_SkipTaskbar false