summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--build-fixes.patch20
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a2372b765d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = keepass-plugin-rpc
+ pkgdesc = RPC plugin for Keepass
+ pkgver = 1.2.7
+ pkgrel = 2
+ url = http://keefox.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mono
+ depends = keepass
+ source = https://github.com/luckyrat/KeeFox/archive/v1.2.7.tar.gz
+ source = build-fixes.patch
+ md5sums = b854bb627b5477d9ef9ac1becc9e4a63
+ md5sums = 4744511f20a030802cec01e71714b5f3
+
+pkgname = keepass-plugin-rpc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..044024007c81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tilman Blumenbach <tilman AT ax86 DOT net>
+
+pkgname=keepass-plugin-rpc
+pkgver=1.2.7
+pkgrel=2
+pkgdesc="RPC plugin for Keepass"
+arch=(i686 x86_64)
+url="http://keefox.org/"
+license=('GPL')
+depends=(keepass)
+# Technically, mono is already pulled in by the keepass dependency.
+makedepends=(mono)
+source=("https://github.com/luckyrat/KeeFox/archive/v${pkgver}.tar.gz"
+ build-fixes.patch)
+
+prepare() {
+ cd "$srcdir/KeeFox-$pkgver"
+
+ # Need --binary option because of DOS line endings.
+ patch --binary -Np1 -i "$srcdir/build-fixes.patch"
+}
+
+build() {
+ cd "$srcdir/KeeFox-$pkgver/KeePassRPC"
+
+ xbuild /property:Configuration=Release KeePassRPC.csproj
+}
+
+package() {
+ cd "$srcdir/KeeFox-$pkgver/KeePassRPC/bin/Release"
+
+ for f in Jayrock*.dll KeePassRPC.dll; do
+ install -m 644 -D "$f" "${pkgdir}/usr/share/keepass/plugins/rpc/${f}"
+ done
+}
+
+md5sums=('b854bb627b5477d9ef9ac1becc9e4a63'
+ '4744511f20a030802cec01e71714b5f3')
diff --git a/build-fixes.patch b/build-fixes.patch
new file mode 100644
index 000000000000..1223a5d9d4b0
--- /dev/null
+++ b/build-fixes.patch
@@ -0,0 +1,20 @@
+--- KeeFox-1.2.7/KeePassRPC/KeePassRPC.csproj 2013-09-03 21:07:46.000000000 +0200
++++ KeeFox-1.2.7/KeePassRPC/KeePassRPC.csproj 2014-02-09 16:07:04.082924522 +0100
+@@ -91,7 +91,7 @@
+ <Reference Include="KeePass, Version=2.1.8.29009, Culture=neutral, PublicKeyToken=7952fc8ece49a093, processorArchitecture=MSIL">
+ <SpecificVersion>False</SpecificVersion>
+ <ExecutableExtension>.exe</ExecutableExtension>
+- <HintPath>..\..\..\Program Files (x86)\KeePass Password Safe 2 DEV\KeePass.exe</HintPath>
++ <HintPath>/usr/share/keepass/KeePass.exe</HintPath>
+ </Reference>
+ <Reference Include="Mono.Security, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756, processorArchitecture=MSIL">
+ <SpecificVersion>False</SpecificVersion>
+@@ -255,7 +255,7 @@
+ <Target Name="AfterBuild">
+ </Target>
+ -->
+- <PropertyGroup>
++ <PropertyGroup Condition="'$(OS)' == 'Windows_NT'">
+ <PreBuildEvent>
+ </PreBuildEvent>
+ <PostBuildEvent>