summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
-rw-r--r--keepass-plugin-rpc.install24
3 files changed, 15 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ff91746751a..0e2cd67d4b6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = keepass-plugin-rpc
- pkgdesc = RPC plugin for Keepass (used by the KeeFox addon for Firefox)
- pkgver = 1.8.0
+ pkgdesc = RPC plugin for Keepass
+ pkgver = 1.9.0
pkgrel = 1
- epoch = 1
url = https://github.com/kee-org/keepassrpc
- install = keepass-plugin-rpc.install
arch = any
license = GPL
depends = keepass
- source = KeePassRPC-1.8.0.plgx::https://github.com/kee-org/keepassrpc/releases/download/v1.8.0/KeePassRPC.plgx
- sha256sums = 8d9d5e390fc4a3b8d6d8f24dd26a712dc032c4ff49708c8ec32c95a2e27594b5
+ source = https://github.com/kee-org/keepassrpc/releases/download/v1.9.0/KeePassRPC.plgx
+ sha256sums = 4b24fc8e47ca70989a7d948397a4707913484027635ad5f8be7f96794cfe0309
pkgname = keepass-plugin-rpc
diff --git a/PKGBUILD b/PKGBUILD
index 808f65123a7f..4c21fe94f90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,16 @@
-# Maintainer: Tilman Blumenbach <tilman AT ax86 DOT net>
-#
-# Credits:
-# - Thanks to gamezelda and Magotchi for pointing out that newer versions
-# of the plugin are also hosted on GitHub, which makes downloading the
-# latest version a lot easier.
-
+# Maintainer: scan
pkgname=keepass-plugin-rpc
-epoch=1
-pkgver=1.8.0
-_git_tag=1.8.0
+pkgver=1.9.0
pkgrel=1
-pkgdesc="RPC plugin for Keepass (used by the KeeFox addon for Firefox)"
-arch=(any)
-url="https://github.com/kee-org/keepassrpc"
+pkgdesc="RPC plugin for Keepass"
license=('GPL')
-depends=(keepass)
-install="${pkgname}.install"
-source=("KeePassRPC-${pkgver}.plgx::https://github.com/kee-org/keepassrpc/releases/download/v${_git_tag}/KeePassRPC.plgx")
-
-package() {
- cd "$srcdir"
+depends=("keepass")
+url="https://github.com/kee-org/keepassrpc"
+source=(https://github.com/kee-org/keepassrpc/releases/download/v1.9.0/KeePassRPC.plgx)
+arch=(any)
+sha256sums=('4b24fc8e47ca70989a7d948397a4707913484027635ad5f8be7f96794cfe0309')
- install -m 644 -D "KeePassRPC-${pkgver}.plgx" "${pkgdir}/usr/share/keepass/plugins/KeePassRPC.plgx"
+package(){
+ mkdir -p "${pkgdir}"/usr/share/keepass/Plugins
+ install -m644 KeePassRPC.plgx "${pkgdir}"/usr/share/keepass/Plugins
}
-
-sha256sums=('8d9d5e390fc4a3b8d6d8f24dd26a712dc032c4ff49708c8ec32c95a2e27594b5')
diff --git a/keepass-plugin-rpc.install b/keepass-plugin-rpc.install
deleted file mode 100644
index c34f833c1499..000000000000
--- a/keepass-plugin-rpc.install
+++ /dev/null
@@ -1,24 +0,0 @@
-## arg 1: the new package version
-post_install() {
- echo "> If you are using KeeFox, please change the \"KeePass installation"
- echo "> directory\" setting on the \"KeePass\" tab in the KeeFox addon"
- echo "> options to the following value:"
- echo "> /usr/share/keepass"
-
-}
-
-## arg 1: new package full version string
-## arg 2: old package full version string
-post_upgrade() {
- if [ "$2" = "1.4.4-1" ]; then
- echo "> Important change:"
- echo "> -----------------"
- echo ">"
- echo "> The plugin has been moved to the following location:"
- echo "> /usr/share/keepass/plugins"
- echo ">"
- echo "> If you are using KeeFox, then please set this as the \"KeePassRPC"
- echo "> installation directory\" in the KeeFox addon options on the"
- echo "> \"KeePass\" tab."
- fi
-}