summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--hide-menubar.patch12
3 files changed, 3 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beb085109ae8..2491c2c9d269 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = keeweb
pkgdesc = Desktop password manager compatible with KeePass databases
- pkgver = 1.12.2
+ pkgver = 1.12.3
pkgrel = 1
url = https://keeweb.info
arch = any
@@ -14,12 +14,10 @@ pkgbase = keeweb
depends = electron
optdepends = xdotool: for auto-type
conflicts = keeweb-desktop
- source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.12.2
- source = hide-menubar.patch
+ source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.12.3
source = keeweb.sh
source = package.json.patch.js
sha1sums = SKIP
- sha1sums = a55c2ed276c6073b7954452cdc88209633d51ace
sha1sums = c925527f25e732d58438ee16b1c93b33be7bf9c4
sha1sums = 19c9db9079a08e82b5418609596201b358ac815d
diff --git a/PKGBUILD b/PKGBUILD
index f0a1153c3f96..06e0c242b582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: surefire@cryptomile.net
pkgname=keeweb
-pkgver=1.12.2
+pkgver=1.12.3
pkgrel=1
pkgdesc="Desktop password manager compatible with KeePass databases"
arch=('any')
@@ -20,21 +20,17 @@ optdepends=('xdotool: for auto-type')
conflicts=('keeweb-desktop')
source=(
"${pkgname}::git+https://github.com/keeweb/keeweb.git#tag=v${pkgver}"
- 'hide-menubar.patch'
'keeweb.sh'
'package.json.patch.js'
)
sha1sums=('SKIP'
- 'a55c2ed276c6073b7954452cdc88209633d51ace'
'c925527f25e732d58438ee16b1c93b33be7bf9c4'
'19c9db9079a08e82b5418609596201b358ac815d')
prepare() {
cd "${pkgname}"
- patch -Np1 -i ../hide-menubar.patch
-
# remove extra dependencies
node ../package.json.patch.js
diff --git a/hide-menubar.patch b/hide-menubar.patch
deleted file mode 100644
index 92ebf9816468..000000000000
--- a/hide-menubar.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/desktop/app.js b/desktop/app.js
-index 75737e1..c75f793 100644
---- a/desktop/app.js
-+++ b/desktop/app.js
-@@ -137,6 +137,7 @@ function readAppSettings() {
- function createMainWindow() {
- const appSettings = readAppSettings();
- const windowOptions = {
-+ autoHideMenuBar: true,
- show: false,
- width: 1000, height: 700, minWidth: 700, minHeight: 400,
- titleBarStyle: appSettings ? appSettings.titlebarStyle : undefined,