summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--67e917af3dcd9d78273774e7061f74d893b5523b.patch10
-rw-r--r--PKGBUILD11
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8da6414fb43e..55bbb7791b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = keeweb
pkgdesc = Desktop password manager compatible with KeePass databases
- pkgver = 1.18.5
+ pkgver = 1.18.6
pkgrel = 1
url = https://keeweb.info
arch = any
@@ -10,15 +10,16 @@ pkgbase = keeweb
makedepends = libsass
makedepends = npm
makedepends = nodejs
- depends = electron
+ depends = electron12
depends = org.freedesktop.secrets
conflicts = keeweb-desktop
- source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.18.5
+ source = keeweb::git+https://github.com/keeweb/keeweb.git#tag=v1.18.6
source = git+https://github.com/keeweb/keeweb-native-modules.git#tag=0.11.7
source = package.json.patch.js
+ source = 67e917af3dcd9d78273774e7061f74d893b5523b.patch
sha1sums = SKIP
sha1sums = SKIP
sha1sums = 5e2a12694cf56ec9ed558554819dba0187e7fbdc
+ sha1sums = 3b6341f657421899d4e4078b799bece7d93587e5
pkgname = keeweb
-
diff --git a/67e917af3dcd9d78273774e7061f74d893b5523b.patch b/67e917af3dcd9d78273774e7061f74d893b5523b.patch
new file mode 100644
index 000000000000..4163bf508c09
--- /dev/null
+++ b/67e917af3dcd9d78273774e7061f74d893b5523b.patch
@@ -0,0 +1,10 @@
+--- a/node_modules/keyboard-auto-type/keyboard-auto-type/keyboard-auto-type/src/linux/x11-keysym-map.cpp 2021-06-18 08:55:59.377894826 +0300
++++ b/node_modules/keyboard-auto-type/keyboard-auto-type/keyboard-auto-type/src/linux/x11-keysym-map.cpp 2021-06-18 08:55:20.207207580 +0300
+@@ -4,6 +4,7 @@
+
+ #include <algorithm>
+ #include <array>
++#include <limits>
+
+ namespace keyboard_auto_type {
+
diff --git a/PKGBUILD b/PKGBUILD
index 99263568a75d..b795ed4611fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: surefire@cryptomile.net
pkgname=keeweb
-pkgver=1.18.5
-_electron=electron
+pkgver=1.18.6
+_electron=electron12
pkgrel=1
pkgdesc="Desktop password manager compatible with KeePass databases"
arch=('any')
@@ -24,11 +24,13 @@ source=(
"${pkgname}::git+https://github.com/keeweb/keeweb.git#tag=v${pkgver}"
"git+https://github.com/keeweb/keeweb-native-modules.git#tag=0.11.7"
'package.json.patch.js'
+ '67e917af3dcd9d78273774e7061f74d893b5523b.patch'
)
sha1sums=('SKIP'
'SKIP'
- '5e2a12694cf56ec9ed558554819dba0187e7fbdc')
+ '5e2a12694cf56ec9ed558554819dba0187e7fbdc'
+ '3b6341f657421899d4e4078b799bece7d93587e5')
case "$CARCH" in
i686) _arch=ia32;;
@@ -81,6 +83,9 @@ build() {
npm install --ignore-scripts
+ # https://github.com/antelle/keyboard-auto-type/commit/67e917af3dcd9d78273774e7061f74d893b5523b
+ patch -Np1 <"${srcdir}/67e917af3dcd9d78273774e7061f74d893b5523b.patch"
+
HOME="${srcdir}/.electron-gyp" \
npx electron-rebuild --arch="${_arch}" --version="$(</usr/lib/${_electron}/version)" --only=argon2,keytar,usb-detection,yubikey-chalresp,keyboard-auto-type
}