summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b439a700ef0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Wed Jan 3 08:00:03 UTC 2018
+pkgbase = kepubify-bin
+ pkgdesc = Convert your ePubs into kepubs, with a easy-to-use command-line tool.
+ pkgver = 1.3.5
+ pkgrel = 1
+ url = https://codeship.com
+ arch = x86_64
+ license = MIT
+ source_x86_64 = https://github.com/geek1011/kepubify/releases/download/v1.3.5/kepubify-linux-64bit
+ md5sums_x86_64 = 791bb2f3867dc0c2c18298a9dd8cb3fb
+
+pkgname = kepubify-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cdc4a8afa68e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+kepubify-linux-64bit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ec4e26330c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+
+pkgname=kepubify-bin
+_pkgname=kepubify
+pkgver=1.3.5
+pkgrel=1
+pkgdesc="Convert your ePubs into kepubs, with a easy-to-use command-line tool."
+arch=('x86_64')
+url="https://codeship.com"
+license=('MIT')
+source_x86_64=(https://github.com/geek1011/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-linux-64bit)
+md5sums_x86_64=('791bb2f3867dc0c2c18298a9dd8cb3fb')
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -m755 "${srcdir}/${_pkgname}-linux-64bit" "${pkgdir}"/usr/bin/${_pkgname}
+}