summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..955bf8c5cb68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = key2root
+ pkgdesc = Authenticate with keyfile and run a process as root
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://maandree.se/proj/key2root.html
+ arch = x86_64
+ license = custom:ISC
+ source = key2root-1.0.tar.gz::https://git.maandree.se/key2root/snapshot/key2root-1.0.tar.gz
+ sha256sums = c365a009daf784398a0d93b0875a263a078cbc8f417c9e262bd83bab57b0a19e
+
+pkgname = key2root
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f5adb3bb74c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+pkgname=key2root
+pkgver=1.0
+pkgrel=1
+pkgdesc="Authenticate with keyfile and run a process as root"
+arch=('x86_64')
+url="https://maandree.se/proj/key2root.html"
+license=('custom:ISC')
+source=($pkgname-$pkgver.tar.gz::https://git.maandree.se/$pkgname/snapshot/$pkgname-$pkgver.tar.gz)
+sha256sums=(c365a009daf784398a0d93b0875a263a078cbc8f417c9e262bd83bab57b0a19e)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+}