summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.in2
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 193fb027543e..a39b86270294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kicad-nightly
pkgdesc = Electronic schematic and printed circuit board (PCB) design tools
- pkgver = 5.99.0_9739_g6a369b230f
+ pkgver = 5.99.0_9795_gc3c3649211
pkgrel = 1
url = http://kicad-pcb.org/
arch = x86_64
@@ -12,6 +12,8 @@ pkgbase = kicad-nightly
makedepends = boost
makedepends = swig
makedepends = ninja
+ makedepends = tar
+ makedepends = gz
depends = wxgtk3
depends = python
depends = boost-libs
@@ -24,7 +26,7 @@ pkgbase = kicad-nightly
optdepends = kicad-library-nightly: for footprints and symbols
optdepends = kicad-library-3d-nightly: for 3d models of components
options = !strip
- source = git+https://gitlab.com/kicad/code/kicad.git#commit=6a369b230f
+ source = git+https://gitlab.com/kicad/code/kicad.git#commit=c3c3649211
source = kicad-nightly.env
sha256sums = SKIP
sha256sums = fce26af6b9c181a99197bfc9bc6c778561ad55a375480f4d0d73bb34078b5d18
diff --git a/PKGBUILD b/PKGBUILD
index d7be9e2d79fd..de09c94187ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Rachel Mant <dx-mon@users.sourceforge.net>
pkgname=kicad-nightly
-pkgver=5.99.0_9739_g6a369b230f
+pkgver=5.99.0_9795_gc3c3649211
pkgrel=1
pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja')
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja' 'tar' 'gz')
options=('!strip')
optdepends=(
'kicad-library-nightly: for footprints and symbols'
'kicad-library-3d-nightly: for 3d models of components'
)
source=(
- 'git+https://gitlab.com/kicad/code/kicad.git'#commit=6a369b230f
+ 'git+https://gitlab.com/kicad/code/kicad.git'#commit=c3c3649211
'kicad-nightly.env'
)
sha256sums=(
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 36f3f229bb30..2b131ce303d7 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -8,7 +8,7 @@ arch=('x86_64')
url='http://kicad-pcb.org/'
license=('GPL')
depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
-makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja')
+makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja' 'tar' 'gz')
options=('!strip')
optdepends=(
'kicad-library-nightly: for footprints and symbols'