summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--kind.install8
3 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 305e4f4c945a..bb0f7e2c0c45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = kind
pkgdesc = Kubernetes IN Docker - local clusters for testing Kubernetes
pkgver = 0.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://kind.sigs.k8s.io/
+ install = kind.install
arch = x86_64
arch = aarch64
arch = arm
@@ -14,7 +15,6 @@ pkgbase = kind
depends = glibc
optdepends = docker: container engine
optdepends = podman: container engine
- optdepends = bazel: building node images with bazel
optdepends = kubectl: for managing Kubernetes clusters
source = https://github.com/kubernetes-sigs/kind/archive/v0.11.0/kind-0.11.0.tar.gz
sha256sums = c78bed3a39afd2e523b38256b7f16445d0ad4b8b25f18b5766005e095af772cd
diff --git a/PKGBUILD b/PKGBUILD
index b0b84afefbe3..9c46eb637f38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <>
pkgname=kind
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc='Kubernetes IN Docker - local clusters for testing Kubernetes'
arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
url='https://kind.sigs.k8s.io/'
@@ -12,9 +12,9 @@ optdepends=(
'docker: container engine'
'podman: container engine'
- 'bazel: building node images with bazel'
'kubectl: for managing Kubernetes clusters'
)
+install=kind.install
source=("https://github.com/kubernetes-sigs/kind/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
sha256sums=('c78bed3a39afd2e523b38256b7f16445d0ad4b8b25f18b5766005e095af772cd')
@@ -27,13 +27,18 @@ build() {
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
export CGO_LDFLAGS="$LDFLAGS"
- export GOFLAGS='-buildmode=pie -mod=readonly -modcacherw -trimpath'
- go build -o "$pkgname" -ldflags "-linkmode=external -X sigs.k8s.io/kind/pkg/cmd/kind/version.GitCommit=$_commit"
+ export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+
+ go build -o "$pkgname" -ldflags="-linkmode=external \
+ -X sigs.k8s.io/kind/pkg/cmd/kind/version.GitCommit=$_commit"
+
+ ./"$pkgname" completion bash >completion.bash
+ ./"$pkgname" completion zsh >completion.zsh
}
package() {
cd "$pkgname-$pkgver"
install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
- ./"$pkgname" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/$pkgname"
- ./"$pkgname" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -Dm644 completion.zsh "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
}
diff --git a/kind.install b/kind.install
new file mode 100644
index 000000000000..354888f068c7
--- /dev/null
+++ b/kind.install
@@ -0,0 +1,8 @@
+# vim: ft=bash
+post_install() {
+ echo "\
+ Rootless docker/podman (with cgroups v2) is supported starting >=0.11.0
+ Checkout the guide: https://kind.sigs.k8s.io/docs/user/rootless/"
+}
+
+post_upgrade() { post_install; }