summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--iptables.conf2
-rw-r--r--kind.install5
4 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4859d530760c..caf6416d2cbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kind
pkgdesc = Kubernetes IN Docker - local clusters for testing Kubernetes
pkgver = 0.11.1
- pkgrel = 1
+ pkgrel = 2
url = https://kind.sigs.k8s.io/
install = kind.install
arch = x86_64
@@ -17,7 +17,8 @@ pkgbase = kind
optdepends = podman: container engine
optdepends = kubectl: for managing Kubernetes clusters
source = https://github.com/kubernetes-sigs/kind/archive/v0.11.1/kind-0.11.1.tar.gz
+ source = iptables.conf
sha256sums = 95ce0e7b01c00be149e5bd777936cef3f79ba7f1f3e5872e7ed60595858a2491
+ sha256sums = fac7413afb24af54abd8cbe5e1424723ea6bccf0c26205670b7f3f4fe0f98f0d
pkgname = kind
-
diff --git a/PKGBUILD b/PKGBUILD
index f27e6f53a546..16365989cc8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <>
pkgname=kind
pkgver=0.11.1
-pkgrel=1
+pkgrel=2
pkgdesc='Kubernetes IN Docker - local clusters for testing Kubernetes'
arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
url='https://kind.sigs.k8s.io/'
@@ -15,8 +15,10 @@ optdepends=(
'kubectl: for managing Kubernetes clusters'
)
install=kind.install
-source=("https://github.com/kubernetes-sigs/kind/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('95ce0e7b01c00be149e5bd777936cef3f79ba7f1f3e5872e7ed60595858a2491')
+source=("https://github.com/kubernetes-sigs/kind/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+ iptables.conf)
+sha256sums=('95ce0e7b01c00be149e5bd777936cef3f79ba7f1f3e5872e7ed60595858a2491'
+ 'fac7413afb24af54abd8cbe5e1424723ea6bccf0c26205670b7f3f4fe0f98f0d')
build() {
local _commit
@@ -37,6 +39,8 @@ build() {
}
package() {
+ install -Dm755 iptables.conf -t "$pkgdir/etc/modules-load.d"
+
cd "$pkgname-$pkgver"
install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/$pkgname"
diff --git a/iptables.conf b/iptables.conf
new file mode 100644
index 000000000000..f4ae9f74ec77
--- /dev/null
+++ b/iptables.conf
@@ -0,0 +1,2 @@
+iptables_nat
+ip6tables_nat
diff --git a/kind.install b/kind.install
index 354888f068c7..d9e3f54847ff 100644
--- a/kind.install
+++ b/kind.install
@@ -2,7 +2,10 @@
post_install() {
echo "\
Rootless docker/podman (with cgroups v2) is supported starting >=0.11.0
- Checkout the guide: https://kind.sigs.k8s.io/docs/user/rootless/"
+ Checkout the guide: https://kind.sigs.k8s.io/docs/user/rootless/
+
+ To use podman instead of docker, run
+ KIND_EXPERIMENTAL_PROVIDER=podman kind create cluster"
}
post_upgrade() { post_install; }