summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD35
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ed3754dfe7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = kirogi-git
+ pkgdesc = A ground control application for drones.Take to the skies, open source style
+ pkgver = 7467269
+ pkgrel = 1
+ url = https://invent.kde.org/kde/kirogi
+ arch = any
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = make
+ makedepends = gst-plugin-qmlgl
+ makedepends = icu
+ depends = extra-cmake-modules
+ depends = qt5-base
+ depends = qt5-gamepad
+ depends = qt5-location
+ depends = kdnssd
+ depends = kconfig
+ depends = kcoreaddons
+ depends = kirigami2
+ depends = gettext
+ depends = pkgconf
+ optdepends = mavlink
+ provides = kirogi
+ replaces = kirogi
+ source = git+https://invent.kde.org/kde/kirogi
+ md5sums = SKIP
+
+pkgname = kirogi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1379e2db9ce3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Manav Sethi <manav.sethi@outlook.in>
+pkgname=kirogi-git
+pkgver=7467269
+pkgrel=1
+epoch=
+pkgdesc="A ground control application for drones.Take to the skies, open source style"
+arch=('any')
+url="https://invent.kde.org/kde/kirogi"
+license=('GPL' 'LGPL')
+groups=()
+depends=(extra-cmake-modules qt5-base qt5-gamepad qt5-location kdnssd kconfig kcoreaddons kirigami2 gettext pkgconf)
+makedepends=(git make gst-plugin-qmlgl icu)
+checkdepends=()
+optdepends=(mavlink)
+provides=(kirogi)
+conflicts=()
+replaces=(kirogi)
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+build () {
+ cd kirogi
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+}
+package() {
+ cd kirogi/build
+ sudo make DESTDIR="$pkgdir/" install
+}