summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23dbf9c317ba..739a679d7bac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,9 +29,14 @@ pkgver() {
build() {
cd "$srcdir/klayout"
+ # Get thread count to multithread build process.
+ threads="$(grep -c ^processor /proc/cpuinfo)"
+
build_opt="-qmake /usr/bin/qmake
-ruby /usr/bin/ruby-2.3
- -python /usr/bin/python3"
+ -python /usr/bin/python3
+ -j${threads}
+ -qt5"
# apply patch
cd ./src/db/db