summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
-rw-r--r--klick-sconstruct-py3.patch22
4 files changed, 47 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2303e1a32025..f4d27455da62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
-# Generated by mksrcinfo v8
-# Tue Jan 19 23:53:32 UTC 2016
pkgbase = klick-git
pkgdesc = An advanced command-line based metronome for JACK
pkgver = r174.c050710
- pkgrel = 2
+ pkgrel = 3
url = http://das.nasophon.de/klick/
arch = i686
arch = x86_64
license = GPL
- makedepends = scons
makedepends = boost
+ makedepends = git
+ makedepends = scons
depends = jack
depends = liblo
depends = rubberband
provides = klick
conflicts = klick
source = klick::git://github.com/dsacre/klick.git
+ source = klick-sconstruct-py3.patch
sha256sums = SKIP
+ sha256sums = 29d59dfb3cae6b8e0e77362391280ef32a18b3f7e33413921917ce465c5543e9
pkgname = klick-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b63dc864c66d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+klick/
+pkg/
+src/
+klick-git-*.pkg.tar.xz
+klick-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 946a8a89a132..6fa9eb795853 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Daniel Appelt <daniel.appelt@gmail.com>
# Contributor: Christoph Zeiler <rabyte*gmail>
# Contributor: Philipp Überbacher <murks at lavabit dot com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
_pkgbasename=klick
pkgname=${_pkgbasename}-git
pkgver=r174.c050710
-pkgrel=2
+pkgrel=3
pkgdesc="An advanced command-line based metronome for JACK"
arch=('i686' 'x86_64')
url="http://das.nasophon.de/klick/"
license=('GPL')
depends=('jack' 'liblo' 'rubberband')
-makedepends=('scons' 'boost')
+makedepends=('boost' 'git' 'scons')
provides=("${_pkgbasename}")
conflicts=("${_pkgbasename}")
-source=("${_pkgbasename}::git://github.com/dsacre/klick.git")
-sha256sums=('SKIP')
+source=("${_pkgbasename}::git://github.com/dsacre/klick.git"
+ 'klick-sconstruct-py3.patch')
+sha256sums=('SKIP'
+ '29d59dfb3cae6b8e0e77362391280ef32a18b3f7e33413921917ce465c5543e9')
pkgver() {
cd "${srcdir}/${_pkgbasename}"
@@ -22,6 +26,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_pkgbasename}"
+
+ patch -p1 -N -i "${srcdir}"/klick-sconstruct-py3.patch
+}
+
build() {
cd "${srcdir}/${_pkgbasename}"
@@ -31,6 +41,5 @@ build() {
package() {
cd "${srcdir}/${_pkgbasename}"
- scons DESTDIR=${pkgdir} install
+ scons DESTDIR="${pkgdir}" install
}
-
diff --git a/klick-sconstruct-py3.patch b/klick-sconstruct-py3.patch
new file mode 100644
index 000000000000..f43dd978bf0b
--- /dev/null
+++ b/klick-sconstruct-py3.patch
@@ -0,0 +1,22 @@
+diff --git a/SConstruct b/SConstruct
+index 95f9c43..dc441cd 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -11,13 +11,13 @@ env = Environment(
+ ENV = os.environ,
+ )
+
+-if os.environ.has_key('CXX'):
++if 'CXX' in os.environ:
+ env.Replace(CXX = os.environ['CXX'])
+-if os.environ.has_key('CXXFLAGS'):
++if 'CXXFLAGS' in os.environ:
+ env.Append(CXXFLAGS = SCons.Util.CLVar(os.environ['CXXFLAGS']))
+-if os.environ.has_key('CPPFLAGS'):
++if 'CPPFLAGS' in os.environ:
+ env.Append(CXXFLAGS = SCons.Util.CLVar(os.environ['CPPFLAGS']))
+-if os.environ.has_key('LDFLAGS'):
++if 'LDFLAGS' in os.environ:
+ env.Append(LINKFLAGS = SCons.Util.CLVar(os.environ['LDFLAGS']))
+
+ # build options