summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da8fb85950f8..bef5013e9943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = klipper-git
url = https://github.com/KevinOConnor/klipper
arch = x86_64
arch = i686
+ arch = arm
+ arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPLv3
makedepends = git
depends = python2-cffi
@@ -28,9 +31,9 @@ pkgbase = klipper-git
md5sums = 4b915228f21e65dbe143ad93074d91e9
md5sums = 61912d101dc7c68c7314882b80621454
md5sums = 218dfe92aa1a1c2654be11cca99e6cd3
- depends_x86_64 = arm-none-eabi-gcc
- depends_x86_64 = arm-none-eabi-newlib
- depends_x86_64 = stm32flash
+ optdepends_x86_64 = arm-none-eabi-gcc: for ARM MCU firmware compilation
+ optdepends_x86_64 = arm-none-eabi-newlib: for ARM MCU firmware compilation
+ optdepends_x86_64 = stm32flash: for flashing firmware on STM MCU
pkgname = klipper-git
diff --git a/PKGBUILD b/PKGBUILD
index 8c15c3fae5be..4362725e3d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,10 @@ depends=(
avr-binutils
avr-libc
)
-depends_x86_64=(
- arm-none-eabi-gcc
- arm-none-eabi-newlib
- stm32flash
+optdepends_x86_64=(
+ 'arm-none-eabi-gcc: for ARM MCU firmware compilation'
+ 'arm-none-eabi-newlib: for ARM MCU firmware compilation'
+ 'stm32flash: for flashing firmware on STM MCU'
)
makedepends=('git')
provides=("${pkgname%-git}")