summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--klook-git.install11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a7da3dcfdce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = klook-git
+ pkgdesc = A quick file content preview application that supports integration with Dolphin
+ pkgver = v2.0_10_5_gf01e033
+ pkgrel = 1
+ url = https://abf.rosalinux.ru/uxteam/klook-devel
+ install = klook-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = git
+ depends = kdebase-runtime
+ source = git+https://abf.rosalinux.ru/uxteam/klook-devel.git
+ md5sums = SKIP
+
+pkgname = klook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0d582b60d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: prettyvanilla <prettyvanilla at posteo dot at>
+# Contributor: Dany Martineau <dany.luc.martineau at gmail dot com>
+
+pkgname=klook-git
+_pkgname="klook-devel"
+pkgver=v2.0_10_5_gf01e033
+pkgrel=1
+pkgdesc="A quick file content preview application that supports integration with Dolphin"
+arch=('i686' 'x86_64')
+url="https://abf.rosalinux.ru/uxteam/klook-devel"
+license=('GPL')
+depends=('kdebase-runtime')
+makedepends=('automoc4' 'cmake' 'git')
+install="${pkgname}.install"
+source=("git+https://abf.rosalinux.ru/uxteam/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo $(git describe --tags | sed 's/-/_/g')
+}
+
+build() {
+ cd "${_pkgname}"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/klook-git.install b/klook-git.install
new file mode 100644
index 000000000000..1c0de2e4fa61
--- /dev/null
+++ b/klook-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}