summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67137af6fa1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kmines-git
+ pkgdesc = The classic Minesweeper game
+ pkgver = 21.11.70_r1718.gfbc18fa
+ pkgrel = 1
+ url = https://apps.kde.org/kmines/
+ arch = x86_64
+ groups = kde-applications-git
+ groups = kde-games-git
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = git
+ makedepends = extra-cmake-modules-git
+ makedepends = kdoctools-git
+ depends = libkdegames-git
+ depends = hicolor-icon-theme
+ provides = kmines
+ conflicts = kmines
+ source = git+https://github.com/KDE/kmines.git
+ sha256sums = SKIP
+
+pkgname = kmines-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2836b044faa2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Merged with official ABS kmines PKGBUILD by João, 2021/08/25 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+
+pkgname=kmines-git
+pkgver=21.11.70_r1718.gfbc18fa
+pkgrel=1
+pkgdesc='The classic Minesweeper game'
+url='https://apps.kde.org/kmines/'
+arch=($CARCH)
+license=(GPL LGPL FDL)
+groups=(kde-applications-git kde-games-git)
+depends=(libkdegames-git hicolor-icon-theme)
+makedepends=(git extra-cmake-modules-git kdoctools-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
+ echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}