summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--kmsrtpendpoint.c.patch13
3 files changed, 5 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6624eef02a5..f54351b25e62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kms-elements
pkgdesc = Kurento server media elements
- pkgver = 6.13.0
+ pkgver = 6.17.0
pkgrel = 1
url = https://github.com/Kurento/kms-elements
arch = any
@@ -13,18 +13,15 @@ pkgbase = kms-elements
depends = gstreamer
depends = gst-plugins-base
depends = gst-plugins-bad
- source = git://github.com/Kurento/kms-elements.git#tag=6.13.0
+ source = git+https://github.com/Kurento/kms-elements.git#tag=6.17.0
source = cmake-boost.patch
source = kmselements.c.patch
source = kmsrecorderendpoint.c.patch
- source = kmsrtpendpoint.c.patch
source = kmswebrtcendpoint.c.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = kms-elements
-
diff --git a/PKGBUILD b/PKGBUILD
index 96f944f26760..1a4d97574565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=kms-elements
-pkgver=6.13.0
+pkgver=6.17.0
pkgrel=1
pkgdesc="Kurento server media elements"
arch=(any)
@@ -8,21 +8,19 @@ license=(apache)
depends=(boost kms-core libnice gstreamer gst-plugins-base gst-plugins-bad)
makedepends=(kms-cmake-utils kurento-module-creator)
source=(
- "git://github.com/Kurento/$pkgname.git#tag=$pkgver"
+ "git+https://github.com/Kurento/$pkgname.git#tag=$pkgver"
cmake-boost.patch
kmselements.c.patch
kmsrecorderendpoint.c.patch
- kmsrtpendpoint.c.patch
kmswebrtcendpoint.c.patch
)
-sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP)
+sha256sums=(SKIP SKIP SKIP SKIP SKIP)
prepare() {
cd "$srcdir/$pkgname"
patch -p0 <"$srcdir/cmake-boost.patch"
patch -p1 <"$srcdir/kmselements.c.patch"
patch -p1 <"$srcdir/kmsrecorderendpoint.c.patch"
- patch -p1 <"$srcdir/kmsrtpendpoint.c.patch"
patch -p1 <"$srcdir/kmswebrtcendpoint.c.patch"
sed -ri -e 's#gstreamer((-[-a-z]+)?)-1\.5#gstreamer\1-1.0#g' {,*/,*/*/,*/*/*/,*/*/*/*/}CMakeLists.txt
}
diff --git a/kmsrtpendpoint.c.patch b/kmsrtpendpoint.c.patch
deleted file mode 100644
index 0eae4905de5d..000000000000
--- a/kmsrtpendpoint.c.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c b/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
-index 0e3de82..1ded70b 100644
---- a/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
-+++ b/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
-@@ -1183,7 +1183,7 @@ kms_rtp_endpoint_plugin_init (GstPlugin * plugin)
-
- GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
- GST_VERSION_MINOR,
-- kmsrtpendpoint,
-+ rtpendpoint,
- "Kurento rtp endpoint",
- kms_rtp_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
- "Kurento Elements", "http://kurento.com/")