summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
-rw-r--r--knossos.desktop8
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fae582a1489
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = knossos
+ pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
+ pkgver = 4.1.2
+ pkgrel = 2
+ url = http://www.knossostool.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = boost
+ depends = glu
+ depends = glut
+ depends = libgl
+ depends = qt5-base
+ depends = qt5-python27
+ depends = quazip-qt5
+ depends = snappy
+ source = https://github.com/knossos-project/knossos/archive/v4.1.2.tar.gz
+ source = knossos.desktop
+ md5sums = c648b510bcec05a914540eea7f577bfa
+ md5sums = 1a2b3733cf5fcb3e1845ce771abb58e9
+
+pkgname = knossos
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6abb4782e71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# makepkg folders
+src
+pkg
+
+# source archives and generated packages
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ec1e7752ad3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KNOSSOS-Team <knossos-team at mpimf-heidelberg.mpg.de>
+#
+# KNOSSOS saves its user preferences in $HOME/.config/MPIMF/
+
+pkgname=knossos
+pkgver=4.1.2
+pkgrel=2
+arch=('x86_64')
+pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
+url="http://www.knossostool.org/"
+license=("GPL2")
+depends=("boost"
+ "glu"
+ "glut"
+ "libgl"
+ "qt5-base"
+ "qt5-python27"
+ "quazip-qt5"
+ "snappy"
+)
+makedepends=("cmake")
+source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
+ "knossos.desktop"
+)
+md5sums=('c648b510bcec05a914540eea7f577bfa'
+ '1a2b3733cf5fcb3e1845ce771abb58e9')
+
+build() {
+ mkdir -p "build-$CHOST-$pkgname-$pkgver"
+ cd "build-$CHOST-$pkgname-$pkgver"
+ cmake ../knossos-$pkgver
+ make
+}
+
+package() {
+ install -Dm755 "build-$CHOST-$pkgname-$pkgver/knossos" "$pkgdir/usr/bin/knossos"
+ install -Dm644 "knossos-$pkgver/resources/icons/knossos.png" "$pkgdir/usr/share/pixmaps/knossos.png"
+ install -Dm644 "knossos.desktop" "$pkgdir/usr/share/applications/knossos.desktop"
+}
diff --git a/knossos.desktop b/knossos.desktop
new file mode 100644
index 000000000000..0dc2762656d5
--- /dev/null
+++ b/knossos.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=KNOSSOS
+Comment=3D image visualisation and annotation tool
+Categories=Qt;Science;
+Exec=/usr/bin/knossos
+Icon=/usr/share/pixmaps/knossos.png
+Terminal=false