summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--GCC8-combat-K4.patch16
-rw-r--r--PKGBUILD81
4 files changed, 77 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8752c6fba75f..05a2ca8f5986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun Feb 12 14:00:53 UTC 2017
pkgbase = knossos4
pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
pkgver = 4.1.2
- pkgrel = 10
- url = http://www.knossostool.org/
+ pkgrel = 17
+ url = https://knossos.app
arch = x86_64
license = GPL2
makedepends = boost
@@ -14,7 +12,7 @@ pkgbase = knossos4
depends = curl
depends = glu
depends = glut
- depends = qt5-python27
+ depends = pythonqt-knossos-git
depends = qt5-tools
depends = quazip-qt5
depends = snappy
@@ -22,12 +20,15 @@ pkgbase = knossos4
source = curl.patch
source = knossos4.desktop
source = qt-5.7.patch
- source = quazip.patch
+ source = GCC8-combat-K4.patch
+ source = https://raw.githubusercontent.com/knossos-project/knossos/464cbb2b13f0142877e70a7d37528a92fe12b99e/CMake/Modules/FindQuaZip.cmake
+ source = https://github.com/knossos-project/knossos/commit/f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
md5sums = c648b510bcec05a914540eea7f577bfa
md5sums = 07e9b7ac1ed5ecd0185ae92e61e97bbb
md5sums = 67a3dfea8d64d8b9eb999f16096819ee
md5sums = 10ac71de3331013293518da4be88cde6
- md5sums = be06cd6e91c80b63b9bfe4184b537d7e
+ md5sums = 9e6daa1198b3f819379995d37178e3d1
+ md5sums = c901e39da0c394200d9f1bb81590d245
+ md5sums = 03c1501a6cb9b5227d27b0cbbe8689e9
pkgname = knossos4
-
diff --git a/.gitignore b/.gitignore
index c6abb4782e71..0b1d092aefad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,7 @@ pkg
# source archives and generated packages
*.tar.*
+
+# downloaded files
+FindQuaZip.cmake
+f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
diff --git a/GCC8-combat-K4.patch b/GCC8-combat-K4.patch
new file mode 100644
index 000000000000..d38a6d9b691e
--- /dev/null
+++ b/GCC8-combat-K4.patch
@@ -0,0 +1,16 @@
+diff --git a/hash_list.h b/hash_list.h
+index 5e817c6e..94921f83 100644
+--- a/hash_list.h
++++ b/hash_list.h
+@@ -42,9 +42,9 @@ class hash_list {
+ using value_type = T;
+ using size_type = std::size_t;
+ using difference_type = std::ptrdiff_t;
+- using reference = reference;
++// using reference = reference;
+ using const_reference = const T &;
+- using iterator = iterator;
++// using iterator = iterator;
+ using const_iterator = typename decltype(data)::const_iterator;
+ using reverse_iterator = std::reverse_iterator<iterator>;
+ using const_reverse_iterator = std::reverse_iterator<const_iterator>;
diff --git a/PKGBUILD b/PKGBUILD
index 31f9277f1cb0..9e0b6d1cc6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,71 @@
-# Maintainer: KNOSSOS-Team <knossos-team ät mpimf-heidelberg.mpg.de>
+# Maintainer: KNOSSOS team <knossosteam ät gmail.com>
# Contributor: Martin Drawitsch <mdraw.gh ät gmail.com>
#
# KNOSSOS saves its user preferences in $HOME/.config/MPIMF/
pkgname=knossos4
pkgver=4.1.2
-pkgrel=10
-arch=('x86_64')
-pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
-url="http://www.knossostool.org/"
-license=("GPL2")
-depends=("curl"
- "glu"
- "glut"
- "qt5-python27"
- "qt5-tools"
- "quazip-qt5"
- "snappy"
+pkgrel=17
+arch=(x86_64)
+pkgdesc='A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.'
+url='https://knossos.app'
+license=(GPL2)
+depends=(curl
+ glu
+ glut
+ pythonqt-knossos-git
+ qt5-tools # Qt5Help
+ quazip-qt5
+ snappy
)
-makedepends=("boost"
- "cmake"
- "libxmu" # CMake wants libxmu for GLUT
- "ninja"
+makedepends=(boost
+ cmake
+ libxmu # CMake wants libxmu for GLUT
+ ninja
)
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
- "curl.patch"
- "knossos4.desktop"
- "qt-5.7.patch"
- "quazip.patch"
+ 'curl.patch'
+ 'knossos4.desktop'
+ 'qt-5.7.patch'
+ 'GCC8-combat-K4.patch'
+ 'https://raw.githubusercontent.com/knossos-project/knossos/464cbb2b13f0142877e70a7d37528a92fe12b99e/CMake/Modules/FindQuaZip.cmake'
+ 'https://github.com/knossos-project/knossos/commit/f3bfcd80dc582248a59b857609a796d133bb1fa5.patch'
)
md5sums=('c648b510bcec05a914540eea7f577bfa'
'07e9b7ac1ed5ecd0185ae92e61e97bbb'
'67a3dfea8d64d8b9eb999f16096819ee'
'10ac71de3331013293518da4be88cde6'
- 'be06cd6e91c80b63b9bfe4184b537d7e')
+ '9e6daa1198b3f819379995d37178e3d1'
+ 'c901e39da0c394200d9f1bb81590d245'
+ '03c1501a6cb9b5227d27b0cbbe8689e9')
prepare() {
- cd "knossos-$pkgver"
- patch -p 1 -i ../curl.patch
- patch -p 1 -i ../quazip.patch
- patch -p 1 -i ../qt-5.7.patch
+ cd "knossos-$pkgver"
+ patch -p1 -i ../curl.patch
+ patch -p1 -i ../qt-5.7.patch
+ patch -p1 -i ../GCC8-combat-K4.patch
+ cp -v ../FindQuaZip.cmake cmake/Modules
+ sed 's|CMake/Modules|cmake/Modules|' -i ../f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
+ sed 's|a/annotation/file_io.cpp|a/file_io.cpp|' -i ../f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
+ sed 's|quazip5/quazip|quazip/quazip|' -i ../f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
+ patch -p1 -i ../f3bfcd80dc582248a59b857609a796d133bb1fa5.patch
+ sed 's/snprintf(remoteURL, CSTRING_SIZE, url.toStdString().c_str());/snprintf(remoteURL, CSTRING_SIZE, "%s", url.toStdString().c_str());/' -i network.cpp
+ sed 's/NOT CMAKE_CXX_COMPILER_ID MATCHES "Clang"/FALSE/' -i CMakeLists.txt # breaks using/linking some std functions (min, max, …)
+ sed '/#include <QThread>/a #include <deque>' -i remote.h
+ sed '/#include <QWaitCondition>/a #include <array>' -i stateInfo.h
+
+ pythonqt="Qt5Python$(pacman -Q python | cut -d' ' -f2 | cut -d. -f1-2 --output-delimiter '')"
+ echo using $pythonqt
+ sed "s/Qt5Python27/$pythonqt/" -i CMakeLists.txt
+ cmake -G Ninja -S "$srcdir/knossos-$pkgver" -B "$srcdir/build-$CHOST-$pkgname"
}
build() {
- mkdir -p "build-$CHOST-$pkgname-$pkgver"
- cd "build-$CHOST-$pkgname-$pkgver"
- cmake -G Ninja ../knossos-$pkgver
- ninja
+ cmake --build "build-$CHOST-$pkgname"
}
package() {
- install -Dm755 "build-$CHOST-$pkgname-$pkgver/knossos" "$pkgdir/usr/bin/knossos4"
- install -Dm644 "knossos-$pkgver/resources/icons/knossos.png" "$pkgdir/usr/share/pixmaps/knossos4.png"
- install -Dm644 "knossos4.desktop" "$pkgdir/usr/share/applications/knossos4.desktop"
+ install -Dm755 "build-$CHOST-$pkgname/knossos" "$pkgdir/usr/bin/knossos4"
+ install -Dm644 "knossos-$pkgver/resources/icons/knossos.png" "$pkgdir/usr/share/pixmaps/knossos4.png"
+ install -Dm644 "knossos4.desktop" "$pkgdir/usr/share/applications/knossos4.desktop"
}