summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--cheat-sse-build.patch11
3 files changed, 5 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de3c00e93d32..402afc662705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Feb 4 20:53:59 UTC 2019
+# Mon Feb 4 21:15:11 UTC 2019
pkgbase = kodi-devel
pkgver = 18.1rc1pre2
- pkgrel = 1
+ pkgrel = 2
url = http://kodi.tv
arch = x86_64
license = GPL2
@@ -75,7 +75,6 @@ pkgbase = kodi-devel
source = http://mirrors.kodi.tv/build-deps/sources/crossguid-8f399e8bd4.tar.gz
source = http://mirrors.kodi.tv/build-deps/sources/fstrcmp-0.7.D001.tar.gz
source = http://mirrors.kodi.tv/build-deps/sources/flatbuffers-1.9.0.tar.gz
- source = cheat-sse-build.patch
source = cpuinfo
source = 00-fix.building.with.mariadb.patch::https://github.com/wsnipex/xbmc/commit/cd20c8eb8a0394db1f028b118c4ca9b91b7e746a.patch
source = 01-PR14924.patch::https://patch-diff.githubusercontent.com/raw/xbmc/xbmc/pull/14924.patch
@@ -112,7 +111,6 @@ pkgbase = kodi-devel
sha256sums = 3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10
sha256sums = e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476
sha256sums = 5ca5491e4260cacae30f1a5786d109230db3f3a6e5a0eb45d0d0608293d247e3
- sha256sums = 304d4581ef024bdb302ed0f2dcdb9c8dea03f78ba30d2a52f4a0d1c8fc4feecd
sha256sums = 27387e49043127f09c5ef0a931fffb864f5730e79629100a6e210b68a1b9f2c1
sha256sums = 849daf1d5b081ef6d0e428bbc7d448799fc43a8ac9e79cd7513de0eb5a91b0bb
sha256sums = 4676b603e0c170f2d627e305560622b72dbdee51c0a221058c350841a814dc39
diff --git a/PKGBUILD b/PKGBUILD
index b38f501b7486..79e570d95956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ pkgbase=kodi-devel
pkgname=('kodi-devel' 'kodi-devel-eventclients' 'kodi-devel-tools-texturepacker' 'kodi-devel-dev')
pkgver=18.1rc1pre2
_major=18.0
-pkgrel=1
+pkgrel=2
_codename=Leia
_tag="$_major-$_codename"
# Found on their respective github release pages. One can check them against
@@ -70,7 +70,6 @@ source=(
"http://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
- 'cheat-sse-build.patch'
'cpuinfo'
'00-fix.building.with.mariadb.patch::https://github.com/wsnipex/xbmc/commit/cd20c8eb8a0394db1f028b118c4ca9b91b7e746a.patch'
# closed milestone patches go here
@@ -120,7 +119,6 @@ sha256sums=('ac5d64d59c6f4811b41a869538506e56c342b530fac97ad9dc9715f3d480e633'
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
'5ca5491e4260cacae30f1a5786d109230db3f3a6e5a0eb45d0d0608293d247e3'
- '304d4581ef024bdb302ed0f2dcdb9c8dea03f78ba30d2a52f4a0d1c8fc4feecd'
'27387e49043127f09c5ef0a931fffb864f5730e79629100a6e210b68a1b9f2c1'
'849daf1d5b081ef6d0e428bbc7d448799fc43a8ac9e79cd7513de0eb5a91b0bb'
'4676b603e0c170f2d627e305560622b72dbdee51c0a221058c350841a814dc39'
@@ -155,9 +153,9 @@ prepare() {
cd "xbmc-$_tag"
- # detect if building in arch chroot
+ # detect if building in arch chroot using $pkgname rather than hard coping it into a patch
if [[ "$srcdir" =~ ^\/build.* ]]; then
- patch -Np1 -i ../cheat-sse-build.patch
+ sed s"|exec_program(cat ARGS \"/proc/cpuinfo\" OUTPUT_VARIABLE CPUINFO)|exec_program(cat ARGS \"/build/$pkgname/src/cpuinfo\" OUTPUT_VARIABLE CPUINFO)|" cmake/modules/FindSSE.cmake
fi
local src
diff --git a/cheat-sse-build.patch b/cheat-sse-build.patch
deleted file mode 100644
index 5eb3dc127d6e..000000000000
--- a/cheat-sse-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/cmake/modules/FindSSE.cmake 2017-08-22 09:29:22.000000000 +0200
-+++ b/cmake/modules/FindSSE.cmake 2018-01-06 19:36:32.716303559 +0100
-@@ -4,7 +4,7 @@
-
- if(CMAKE_SYSTEM_NAME MATCHES "Linux")
- if(CPU MATCHES "x86_64" OR CPU MATCHES "i.86")
-- exec_program(cat ARGS "/proc/cpuinfo" OUTPUT_VARIABLE CPUINFO)
-+ exec_program(cat ARGS "/build/kodi/src/cpuinfo" OUTPUT_VARIABLE CPUINFO)
-
- string(REGEX REPLACE "^.*(sse).*$" "\\1" _SSE_THERE ${CPUINFO})
- string(COMPARE EQUAL "sse" "${_SSE_THERE}" _SSE_TRUE)