summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD46
-rw-r--r--removestupidremarks.patch15
3 files changed, 26 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f631064a7e3..eb73778f5b42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kodi-eggz
- pkgver = 19.0
+ pkgver = 21.0
pkgrel = 1
url = https://kodi.tv
arch = x86_64
@@ -52,17 +52,17 @@ pkgbase = kodi-eggz
makedepends = meson
makedepends = gtest
makedepends = fstrcmp
- makedepends = spdlog
+ makedepends = flatbuffers
+ makedepends = ffmpeg
+ makedepends = jre8-openjdk
depends = libcec
depends = tinyxml
depends = shairplay
- source = git+https://github.com/xbmc/xbmc.git#tag=19.0-Matrix
- source = git+https://github.com/xbmc/vfs.rar.git#tag=4.0.0-Matrix
- source = removestupidremarks.patch
+ depends = libdisplay-info
+ source = git+https://github.com/xbmc/xbmc.git
+ source = git+https://github.com/xbmc/vfs.rar.git
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = e89cc7c880b0b10361b882339b542ad49be91ae78de9d4b38ddc08b594734cf5
pkgname = kodi-eggz
pkgdesc = Latest stable-ish kodi build with VFS automaticly installed
-
diff --git a/PKGBUILD b/PKGBUILD
index 280c8e60a36a..22483b4c2d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
pkgbase=kodi-eggz
pkgname=kodi-eggz
-pkgver=19.0
-gittag=19.0-Matrix
-gittagvfs=4.0.0-Matrix
+pkgver=21.0
+gittag=21.0-Omega
pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
-depends=('libcec' 'tinyxml' 'shairplay')
+depends=('libcec' 'tinyxml' 'shairplay' 'libdisplay-info')
makedepends=(
'afpfs-ng' 'bluez-libs' 'cmake' 'curl' 'dav1d' 'doxygen' 'glew'
'gperf' 'hicolor-icon-theme' 'java-runtime' 'libaacs' 'libass'
@@ -17,17 +16,18 @@ makedepends=(
'python-pycryptodomex' 'python-pillow' 'python-pybluez' 'python-simplejson'
'shairplay' 'smbclient' 'taglib' 'tinyxml' 'swig'
'upower' 'giflib' 'rapidjson' 'ghostscript' 'git' 'meson' 'gtest'
- 'fstrcmp' 'spdlog'
+ 'fstrcmp' 'flatbuffers' 'ffmpeg' 'jre8-openjdk'
)
source=(
- "git+https://github.com/xbmc/xbmc.git#tag=$gittag"
- "git+https://github.com/xbmc/vfs.rar.git#tag=$gittagvfs"
- "removestupidremarks.patch"
+ #"git+https://github.com/xbmc/xbmc.git#tag=$gittag"
+ "git+https://github.com/xbmc/xbmc.git"
+ "git+https://github.com/xbmc/vfs.rar.git"
)
-sha256sums=('SKIP'
+
+sha256sums=(
+'SKIP'
'SKIP'
-'e89cc7c880b0b10361b882339b542ad49be91ae78de9d4b38ddc08b594734cf5'
)
pkgver() {
@@ -46,38 +46,30 @@ prepare() {
cmake -DADDONS_TO_BUILD=vfs.rar -DADDON_SRC_PREFIX=../.. -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=../../xbmc/kodi-build/addons -DPACKAGE_ZIP=1 ../../xbmc/cmake/addons
make -j $threads || exit 2
-
- msg "Prepare DEPs"
- msg2 "pivot to git dir"
- cd ${srcdir}/xbmc
- msg2 "making DEP/crossguid"
- make -j $threads -C tools/depends/target/crossguid PREFIX=${srcdir}/usr
- msg2 "making DEP/flatbuffers"
- make -j $threads -C tools/depends/target/flatbuffers PREFIX=${srcdir}/usr
- msg2 "making DEP/libfmt"
- make -j $threads -C tools/depends/target/libfmt PREFIX=${srcdir}/usr
- msg2 "making DEP/libspdlog"
- make -j $threads -C tools/depends/target/libspdlog PREFIX=${srcdir}/usr
-
msg "Prepare Kodi"
+ msg2 "pivot to xbmc builddir"
+ cd ${srcdir}/xbmc
msg2 "Patching Kodisource"
while read patch; do
+ if [ "$patch" == "" ]; then
+ continue
+ fi
echo "Applying $patch"
- git apply $patch || exit 2
+ git apply $patch -v
done <<< $(ls ../../*.patch)
-
-
}
build() {
export PATH="$srcdir/path:$PATH"
msg2 "pivot to kodi git dir"
cd ${srcdir}/xbmc
+ msg2 "checkout working commit"
+ git checkout b35acf7bd3de2d5564d4d30c8800b3da7f9670f0 || exit 2
mkdir ${srcdir}/kodi-build
cd ${srcdir}/kodi-build
msg2 "cmake configure phase"
export APP_RENDER_SYSTEM=gl
- cmake ../xbmc -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_FLATBUFFERS=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON
+ cmake ../xbmc -DAPP_RENDER_SYSTEM=gl -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON -DHAVE_EGLEXTANGLE=1
msg2 "cmake build phase"
cmake --build . -- #VERBOSE=1
diff --git a/removestupidremarks.patch b/removestupidremarks.patch
deleted file mode 100644
index ffa463c3e4bf..000000000000
--- a/removestupidremarks.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/cmake/scripts/common/Platform.cmake b/cmake/scripts/common/Platform.cmake
-index 397d8d46e8..a1d0830bf3 100644
---- a/cmake/scripts/common/Platform.cmake
-+++ b/cmake/scripts/common/Platform.cmake
-@@ -8,7 +8,9 @@ if(CORE_SYSTEM_NAME STREQUAL linux OR CORE_SYSTEM_NAME STREQUAL freebsd)
- set(_DEFAULT_PLATFORM X11 WAYLAND GBM)
-
- if(NOT APP_RENDER_SYSTEM)
-- message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
-+ #message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
-+ # Don't make stupid remarks and just make it work then..?
-+ set(APP_RENDER_SYSTEM "gl")
- endif()
- else()
- string(TOLOWER ${CORE_SYSTEM_NAME} _DEFAULT_PLATFORM)