summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--0001-patching-the-patch-for-crossguid.patch32
-rw-r--r--0002-gcc13-fix-cheevos.patch25
-rw-r--r--0003-gcc13-fix-for-picture.patch25
-rw-r--r--0004-gcc13-fix-for-chararrayparser.patch25
-rw-r--r--0005-gcc13-fix-for-CSSUtils.patch25
-rw-r--r--0006-gcc13-fix-for-ColorManager.patch26
-rw-r--r--0007-gcc13-fix-for-VaapiEGL.patch25
-rw-r--r--0008-gcc13-fix-for-Filesystem.patch25
-rw-r--r--0009-gcc13-fix-for-StreamUtils.patch25
-rw-r--r--0010-gcc13-fix-for-DRMHelpers.patch25
-rw-r--r--PKGBUILD28
12 files changed, 302 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62063002ee42..19f6b6325e79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kodi-eggz
pkgver = 20.1
- pkgrel = 1
+ pkgrel = 2
url = https://kodi.tv
arch = x86_64
license = GPL2
@@ -59,8 +59,28 @@ pkgbase = kodi-eggz
depends = shairplay
source = git+https://github.com/xbmc/xbmc.git#tag=20.1-Nexus
source = git+https://github.com/xbmc/vfs.rar.git#tag=20.1.0-Nexus
+ source = 0001-patching-the-patch-for-crossguid.patch
+ source = 0002-gcc13-fix-cheevos.patch
+ source = 0003-gcc13-fix-for-picture.patch
+ source = 0004-gcc13-fix-for-chararrayparser.patch
+ source = 0005-gcc13-fix-for-CSSUtils.patch
+ source = 0006-gcc13-fix-for-ColorManager.patch
+ source = 0007-gcc13-fix-for-VaapiEGL.patch
+ source = 0008-gcc13-fix-for-Filesystem.patch
+ source = 0009-gcc13-fix-for-StreamUtils.patch
+ source = 0010-gcc13-fix-for-DRMHelpers.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = c5f89b5149b3f9fef7f138a0795402bcda1b6b097fe47e35b661f997fc5eebfd
+ sha256sums = 9d803af68ba613e77490a94a20339a62eec512b96d6e8b3691dbf57a1a8e3ada
+ sha256sums = 8ad1ff33eedb46a89210d62e788ddef68865e7cd7bcac1500e081c32bb009dcc
+ sha256sums = 4ced2587a41d877ae76e1b6ba0b19646b4c7d4e26efa507ba0e2032b7a52dbd9
+ sha256sums = a49508ca05cbd31b21f5942a087ff813d99ad20af503485f55312dd74ca93f6e
+ sha256sums = 9a8aa680d8e74cd07db434fac9a4e8b25884db44d7b393a0d7ab858f8ebbf6f0
+ sha256sums = dd9af3457b281e514921429972eb910b0e558efe76ef8683523c69b736c45dfd
+ sha256sums = 538fc74c2a3712f96269dfdc747ab26c755f50a937051b87e3a6a0eaf6c221ff
+ sha256sums = 4184379ade94fe2d220af451521556d87d524977b34ba807ea2351d2033d170e
+ sha256sums = 5946db48a14a5bca5312a9dd2df42514872da4558b23c654ef45409006cf7435
pkgname = kodi-eggz
pkgdesc = Latest stable-ish kodi build with VFS automaticly installed
diff --git a/0001-patching-the-patch-for-crossguid.patch b/0001-patching-the-patch-for-crossguid.patch
new file mode 100644
index 000000000000..6c50f7b89da4
--- /dev/null
+++ b/0001-patching-the-patch-for-crossguid.patch
@@ -0,0 +1,32 @@
+From eb85b965931b322ccbf0ec41ad92709048c88f09 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 17:56:16 +0200
+Subject: [PATCH] patching the patch
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ .../target/crossguid/002-disable-Wall-error.patch | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/tools/depends/target/crossguid/002-disable-Wall-error.patch b/tools/depends/target/crossguid/002-disable-Wall-error.patch
+index daef659bcd..207054ad0e 100644
+--- a/tools/depends/target/crossguid/002-disable-Wall-error.patch
++++ b/tools/depends/target/crossguid/002-disable-Wall-error.patch
+@@ -16,3 +16,14 @@
+
+ set_target_properties(crossguid
+ PROPERTIES
++
++--- a/include/crossguid/guid.hpp
+++++ b/include/crossguid/guid.hpp
++@@ -36,6 +36,7 @@ THE SOFTWARE.
++ #include <string_view>
++ #include <utility>
++ #include <iomanip>
+++#include <cstdint>
++
++ #define BEGIN_XG_NAMESPACE namespace xg {
++ #define END_XG_NAMESPACE }
+--
+2.40.1
+
diff --git a/0002-gcc13-fix-cheevos.patch b/0002-gcc13-fix-cheevos.patch
new file mode 100644
index 000000000000..ffe36734462d
--- /dev/null
+++ b/0002-gcc13-fix-cheevos.patch
@@ -0,0 +1,25 @@
+From 77fbb896cdcca1f443843afc204db57f91fc1627 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:09:49 +0200
+Subject: [PATCH] gcc13 fix
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/cores/RetroPlayer/cheevos/Cheevos.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/cores/RetroPlayer/cheevos/Cheevos.h b/xbmc/cores/RetroPlayer/cheevos/Cheevos.h
+index 71c5ed5896..70ffe41ed8 100644
+--- a/xbmc/cores/RetroPlayer/cheevos/Cheevos.h
++++ b/xbmc/cores/RetroPlayer/cheevos/Cheevos.h
+@@ -10,6 +10,7 @@
+
+ #include "RConsoleIDs.h"
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+
+--
+2.40.1
+
diff --git a/0003-gcc13-fix-for-picture.patch b/0003-gcc13-fix-for-picture.patch
new file mode 100644
index 000000000000..41a84c77c512
--- /dev/null
+++ b/0003-gcc13-fix-for-picture.patch
@@ -0,0 +1,25 @@
+From 65c3a4f1652ab4a2522cc42a7256a4faadd8d458 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:19:44 +0200
+Subject: [PATCH] gcc13 fix for picture
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/pictures/Picture.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/pictures/Picture.h b/xbmc/pictures/Picture.h
+index 2d469d795d..a7d3781100 100644
+--- a/xbmc/pictures/Picture.h
++++ b/xbmc/pictures/Picture.h
+@@ -11,6 +11,7 @@
+ #include "pictures/PictureScalingAlgorithm.h"
+ #include "utils/Job.h"
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+--
+2.40.1
+
diff --git a/0004-gcc13-fix-for-chararrayparser.patch b/0004-gcc13-fix-for-chararrayparser.patch
new file mode 100644
index 000000000000..cc947e3178fc
--- /dev/null
+++ b/0004-gcc13-fix-for-chararrayparser.patch
@@ -0,0 +1,25 @@
+From 8b86ef2bfc9b39c81a6b360af14e7bae1478136a Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:25:56 +0200
+Subject: [PATCH] gcc13 fix for chararrayparser
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/utils/CharArrayParser.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/utils/CharArrayParser.h b/xbmc/utils/CharArrayParser.h
+index 7e5e314161..3430946dd3 100644
+--- a/xbmc/utils/CharArrayParser.h
++++ b/xbmc/utils/CharArrayParser.h
+@@ -8,6 +8,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ /*!
+--
+2.40.1
+
diff --git a/0005-gcc13-fix-for-CSSUtils.patch b/0005-gcc13-fix-for-CSSUtils.patch
new file mode 100644
index 000000000000..cd3f5ac8b9c6
--- /dev/null
+++ b/0005-gcc13-fix-for-CSSUtils.patch
@@ -0,0 +1,25 @@
+From 8fc4b4ef1afd5018fb5998de2639ab816fb5bf06 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:33:28 +0200
+Subject: [PATCH] gcc13 fix for CSSUtils
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/utils/CSSUtils.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/utils/CSSUtils.cpp b/xbmc/utils/CSSUtils.cpp
+index 96105878e0..329d70cdbc 100644
+--- a/xbmc/utils/CSSUtils.cpp
++++ b/xbmc/utils/CSSUtils.cpp
+@@ -8,6 +8,7 @@
+
+ #include "CSSUtils.h"
+
++#include <cstdint>
+ #include <string>
+
+ namespace
+--
+2.40.1
+
diff --git a/0006-gcc13-fix-for-ColorManager.patch b/0006-gcc13-fix-for-ColorManager.patch
new file mode 100644
index 000000000000..29c10e846993
--- /dev/null
+++ b/0006-gcc13-fix-for-ColorManager.patch
@@ -0,0 +1,26 @@
+From 21bb007e4cecb147e02a3cf8ada5a6a8ac8b6ca5 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:38:13 +0200
+Subject: [PATCH] gcc13 fix for ColorManager
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/cores/VideoPlayer/VideoRenderers/ColorManager.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xbmc/cores/VideoPlayer/VideoRenderers/ColorManager.h b/xbmc/cores/VideoPlayer/VideoRenderers/ColorManager.h
+index b23da958d9..18e9585ce1 100644
+--- a/xbmc/cores/VideoPlayer/VideoRenderers/ColorManager.h
++++ b/xbmc/cores/VideoPlayer/VideoRenderers/ColorManager.h
+@@ -11,7 +11,7 @@
+ #if defined(HAVE_LCMS2)
+ #include <lcms2.h>
+ #endif
+-
++#include <cstdint>
+ #include <string>
+
+ extern "C"
+--
+2.40.1
+
diff --git a/0007-gcc13-fix-for-VaapiEGL.patch b/0007-gcc13-fix-for-VaapiEGL.patch
new file mode 100644
index 000000000000..2808efbf06d7
--- /dev/null
+++ b/0007-gcc13-fix-for-VaapiEGL.patch
@@ -0,0 +1,25 @@
+From 2511caa37c5cb0023bb9726be8cecfb05b44ee53 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:39:16 +0200
+Subject: [PATCH] gcc13 fix for VaapiEGL
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h b/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h
+index 994a4d063b..834e8c18c4 100644
+--- a/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h
++++ b/xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/VaapiEGL.h
+@@ -8,6 +8,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <array>
+
+ #if defined(HAS_GL)
+--
+2.40.1
+
diff --git a/0008-gcc13-fix-for-Filesystem.patch b/0008-gcc13-fix-for-Filesystem.patch
new file mode 100644
index 000000000000..249ec1a136bf
--- /dev/null
+++ b/0008-gcc13-fix-for-Filesystem.patch
@@ -0,0 +1,25 @@
+From aee15b9b76b78155b80e33842480cf27ba42cc58 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:46:05 +0200
+Subject: [PATCH] gcc13 fix for Filesystem
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/platform/Filesystem.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/platform/Filesystem.h b/xbmc/platform/Filesystem.h
+index 3e6b7ec52b..732be9294c 100644
+--- a/xbmc/platform/Filesystem.h
++++ b/xbmc/platform/Filesystem.h
+@@ -8,6 +8,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+ #include <system_error>
+ namespace KODI
+--
+2.40.1
+
diff --git a/0009-gcc13-fix-for-StreamUtils.patch b/0009-gcc13-fix-for-StreamUtils.patch
new file mode 100644
index 000000000000..4de98963181c
--- /dev/null
+++ b/0009-gcc13-fix-for-StreamUtils.patch
@@ -0,0 +1,25 @@
+From 0c6c5437b4874e5e955d4aedeee9da4c011b97dd Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:46:54 +0200
+Subject: [PATCH] gcc13 fix for StreamUtils
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/utils/StreamUtils.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/utils/StreamUtils.h b/xbmc/utils/StreamUtils.h
+index 079cfa3f5c..3d16e8a222 100644
+--- a/xbmc/utils/StreamUtils.h
++++ b/xbmc/utils/StreamUtils.h
+@@ -8,6 +8,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ static constexpr int MP4_BOX_HEADER_SIZE = 8;
+--
+2.40.1
+
diff --git a/0010-gcc13-fix-for-DRMHelpers.patch b/0010-gcc13-fix-for-DRMHelpers.patch
new file mode 100644
index 000000000000..4aea3e6cf284
--- /dev/null
+++ b/0010-gcc13-fix-for-DRMHelpers.patch
@@ -0,0 +1,25 @@
+From 70a5e456c3f758ba4c64d598dce542cd60618487 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Wed, 24 May 2023 18:51:45 +0200
+Subject: [PATCH] gcc13 fix for DRMHelpers
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ xbmc/utils/DRMHelpers.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xbmc/utils/DRMHelpers.h b/xbmc/utils/DRMHelpers.h
+index ea45823179..dcc7f502f3 100644
+--- a/xbmc/utils/DRMHelpers.h
++++ b/xbmc/utils/DRMHelpers.h
+@@ -8,6 +8,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ namespace DRMHELPERS
+--
+2.40.1
+
diff --git a/PKGBUILD b/PKGBUILD
index cc353b4dbf63..959180800018 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=kodi-eggz
pkgver=20.1
gittag=20.1-Nexus
gittagvfs=20.1.0-Nexus
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -23,13 +23,31 @@ makedepends=(
source=(
"git+https://github.com/xbmc/xbmc.git#tag=$gittag"
"git+https://github.com/xbmc/vfs.rar.git#tag=$gittagvfs"
-# "Fix-eglextchromium.patch"
+ "0001-patching-the-patch-for-crossguid.patch"
+ "0002-gcc13-fix-cheevos.patch"
+ "0003-gcc13-fix-for-picture.patch"
+ "0004-gcc13-fix-for-chararrayparser.patch"
+ "0005-gcc13-fix-for-CSSUtils.patch"
+ "0006-gcc13-fix-for-ColorManager.patch"
+ "0007-gcc13-fix-for-VaapiEGL.patch"
+ "0008-gcc13-fix-for-Filesystem.patch"
+ "0009-gcc13-fix-for-StreamUtils.patch"
+ "0010-gcc13-fix-for-DRMHelpers.patch"
)
sha256sums=(
'SKIP'
'SKIP'
-#'faff047172c3b1cccd62aa6e30fd81e97eac7dd964ac19649755600cfe820b1f'
+'c5f89b5149b3f9fef7f138a0795402bcda1b6b097fe47e35b661f997fc5eebfd'
+'9d803af68ba613e77490a94a20339a62eec512b96d6e8b3691dbf57a1a8e3ada'
+'8ad1ff33eedb46a89210d62e788ddef68865e7cd7bcac1500e081c32bb009dcc'
+'4ced2587a41d877ae76e1b6ba0b19646b4c7d4e26efa507ba0e2032b7a52dbd9'
+'a49508ca05cbd31b21f5942a087ff813d99ad20af503485f55312dd74ca93f6e'
+'9a8aa680d8e74cd07db434fac9a4e8b25884db44d7b393a0d7ab858f8ebbf6f0'
+'dd9af3457b281e514921429972eb910b0e558efe76ef8683523c69b736c45dfd'
+'538fc74c2a3712f96269dfdc747ab26c755f50a937051b87e3a6a0eaf6c221ff'
+'4184379ade94fe2d220af451521556d87d524977b34ba807ea2351d2033d170e'
+'5946db48a14a5bca5312a9dd2df42514872da4558b23c654ef45409006cf7435'
)
pkgver() {
@@ -57,7 +75,7 @@ prepare() {
continue
fi
echo "Applying $patch"
- git apply $patch
+ git apply $patch -v
done <<< $(ls ../../*.patch)
}
@@ -69,7 +87,7 @@ build() {
cd ${srcdir}/kodi-build
msg2 "cmake configure phase"
export APP_RENDER_SYSTEM=gl
- cmake ../xbmc -DAPP_RENDER_SYSTEM=gl -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON -DHAVE_EGLEXTANGLE=1
+ cmake ../xbmc -DAPP_RENDER_SYSTEM=gl -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_LIBDISPLAYINFO=ON -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_MYSQLCLIENT=ON -DHAVE_EGLEXTANGLE=1
msg2 "cmake build phase"
cmake --build . -- #VERBOSE=1