summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD50
-rw-r--r--readme.install27
3 files changed, 51 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c6179995d41..3b4b6b350405 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue May 7 19:08:03 UTC 2019
pkgbase = kodi-standalone-service
- pkgdesc = Systemd service to run kodi in stand-alone mode without a DE
- pkgver = 1.95
- pkgrel = 4
+ pkgdesc = Systemd services to run kodi in stand-alone mode without a DE
+ pkgver = 1.137
+ pkgrel = 1
url = https://github.com/graysky2/kodi-standalone-service
install = readme.install
arch = x86_64
- license = GPL
- source = https://github.com/graysky2/kodi-standalone-service/archive/v1.95.tar.gz
- sha256sums = da49c9f1cf6dad28ca88904db1d8b676cd935781a58f7c7917523e28a5bf74c8
-
-pkgname = kodi-standalone-service
- depends = kodi
+ license = MIT
depends = polkit
- depends = xorg-server
- depends = xorg-xinit
-
-pkgname = kodi-standalone-gbm-service
- depends = kodi-gbm
- depends = polkit
- depends = libinput
+ depends = kodi
+ optdepends = cage: for kodi-wayland.service
+ optdepends = xorg-server: for kodi-x11.service
+ optdepends = xorg-xinit: for kodi-x11.service
+ optdepends = xorg-xwayland: for kodi-wayland.service
+ replaces = kodi-standalone-x11-service
+ replaces = kodi-standalone-gbm-service
+ replaces = kodi-standalone-wayland-service
+ backup = etc/conf.d/kodi-standalone
+ source = kodi-standalone-service-v1.137.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.137.tar.gz
+ b2sums = 7ba4612bd089103b78bdf04838f150c2be023b7ccd9814b9d5d3b2d37a266e0db2a1cbc378254a5ba2c98de5f58193b0acf22c5ac104f91f1c9b614624177610
+pkgname = kodi-standalone-service
diff --git a/PKGBUILD b/PKGBUILD
index 43ae3d067247..c5ce271346f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
-pkgbase=kodi-standalone-service
-pkgname=(kodi-standalone-service kodi-standalone-gbm-service)
-pkgver=1.95
-pkgrel=4
-pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
-# Do NOT attempt to use this package on Arch ARM! This is only for x86_64.
-# You have been warned.
-arch=('x86_64')
+pkgname=kodi-standalone-service
+pkgver=1.137
+pkgrel=1
+pkgdesc="Systemd services to run kodi in stand-alone mode without a DE"
+# This is only for x86_64
+# The kodi-rpi packages for ArchARM provide their own versions of this package
+arch=(x86_64)
url="https://github.com/graysky2/kodi-standalone-service"
-license=('GPL')
+license=(MIT)
install=readme.install
-source=("https://github.com/graysky2/$pkgbase/archive/v$pkgver.tar.gz")
-sha256sums=('da49c9f1cf6dad28ca88904db1d8b676cd935781a58f7c7917523e28a5bf74c8')
+depends=(polkit kodi)
+replaces=(kodi-standalone-x11-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
+backup=(etc/conf.d/kodi-standalone)
+optdepends=(
+ 'cage: for kodi-wayland.service'
+ 'xorg-server: for kodi-x11.service'
+ 'xorg-xinit: for kodi-x11.service'
+ 'xorg-xwayland: for kodi-wayland.service'
+)
+source=("$pkgname-v$pkgver.tar.gz::https://github.com/graysky2/$pkgname/archive/v$pkgver.tar.gz")
+b2sums=('7ba4612bd089103b78bdf04838f150c2be023b7ccd9814b9d5d3b2d37a266e0db2a1cbc378254a5ba2c98de5f58193b0acf22c5ac104f91f1c9b614624177610')
-package_kodi-standalone-service() {
- depends=('kodi' 'polkit' 'xorg-server' 'xorg-xinit')
- install -Dm644 "$srcdir/$pkgbase-$pkgver/init/kodi.service" \
- "$pkgdir/usr/lib/systemd/system/kodi.service"
- install -dm 700 "$pkgdir"/var/lib/kodi
- chown 420:420 "$pkgdir"/var/lib/kodi
-}
-
-package_kodi-standalone-gbm-service() {
- depends=('kodi-gbm' 'polkit' 'libinput')
- install -Dm644 "$srcdir/$pkgbase-$pkgver/init/kodi-gbm.service" \
- "$pkgdir/usr/lib/systemd/system/kodi-gbm.service"
- install -dm 700 "$pkgdir"/var/lib/kodi
- chown 420:420 "$pkgdir"/var/lib/kodi
+package() {
+ cd "$pkgname-$pkgver"
+ make
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:
diff --git a/readme.install b/readme.install
index 1c133e985a04..2ebe0f9b0662 100644
--- a/readme.install
+++ b/readme.install
@@ -1,23 +1,18 @@
-post_install() {
- getent group kodi > /dev/null || groupadd -g 420 kodi
- if ! getent passwd kodi > /dev/null; then
- useradd -c 'kodi user' -u 420 -g kodi -G audio,input,network,optical,uucp,video \
- -d /var/lib/kodi -s /usr/bin/nologin kodi
- passwd -l kodi > /dev/null
- [[ ! -d /var/lib/kodi/.kodi ]] &&
- mkdir /var/lib/kodi/.kodi &&
- chown -R kodi:kodi /var/lib/kodi/.kodi
- fi
+post_remove() {
+ echo "--> Optionally remove /var/lib/kodi/ if you wish to remove all data too."
}
-post_upgrade() {
- usermod -g kodi -G audio,input,network,optical,uucp,video kodi
+post_install() {
+ echo "--> Optionally create /etc/conf.d/kodi-standalone if you need to pass"
+ echo "--> any environment variables to the service."
+ post_upgrade
}
-post_remove() {
- echo "==> Optionally delete the kodi user if you are certain no processes are running under it."
- echo "==> userdel kodi"
- echo "==> groupdel kodi"
+post_upgrade() {
+ if find /etc/systemd/system -type l -name 'kodi.service'|grep . &>/dev/null; then
+ echo '--> kodi.service is now kodi-x11.service'
+ echo '--> manually disable the old one and enable the new one'
+ fi
}
# vim:set ts=2 sw=2 et: