summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b8a0c6bc915..17535c1c6aae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = kodi-standalone-service
pkgdesc = Systemd service to run kodi in stand-alone mode without a DE
- pkgver = 1.102
+ pkgver = 1.103
pkgrel = 1
url = https://github.com/graysky2/kodi-standalone-service
install = readme.install
arch = x86_64
license = GPL
- source = kodi-standalone-service-v1.102.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.102.tar.gz
- sha256sums = cdaeed0a2e1b12ab2dc02c147db0f2661d03d426c4780f67434ed03535a3cfd4
+ source = kodi-standalone-service-v1.103.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.103.tar.gz
+ sha256sums = 56b2b16032b29e2f4830cb6997b95329a479e28591044070a63066c3a500c05e
pkgname = kodi-standalone-service
depends = kodi
@@ -20,3 +20,9 @@ pkgname = kodi-standalone-gbm-service
depends = polkit
depends = libinput
+pkgname = kodi-standalone-wayland-service
+ depends = kodi-wayland
+ depends = polkit
+ depends = libinput
+ depends = cage
+
diff --git a/PKGBUILD b/PKGBUILD
index 6d2f93521270..85e6bdf19eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
pkgbase=kodi-standalone-service
-pkgname=(kodi-standalone-service kodi-standalone-gbm-service)
-pkgver=1.102
+pkgname=(kodi-standalone-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
+pkgver=1.103
pkgrel=1
pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
# Do NOT attempt to use this package on Arch ARM! This is only for x86_64.
@@ -12,7 +12,7 @@ url="https://github.com/graysky2/kodi-standalone-service"
license=('GPL')
install=readme.install
source=("$pkgbase-v$pkgver.tar.gz::https://github.com/graysky2/$pkgbase/archive/v$pkgver.tar.gz")
-sha256sums=('cdaeed0a2e1b12ab2dc02c147db0f2661d03d426c4780f67434ed03535a3cfd4')
+sha256sums=('56b2b16032b29e2f4830cb6997b95329a479e28591044070a63066c3a500c05e')
package_kodi-standalone-service() {
depends=('kodi' 'polkit' 'xorg-server' 'xorg-xinit')
@@ -32,4 +32,13 @@ package_kodi-standalone-gbm-service() {
install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-gbm.conf"
}
+package_kodi-standalone-wayland-service() {
+ depends=('kodi-wayland' 'polkit' 'libinput' 'cage')
+
+ cd "$pkgbase-$pkgver"
+ install -Dm644 init/kodi-wayland.service "$pkgdir/usr/lib/systemd/system/kodi-wayland.service"
+ install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-wayland.conf"
+ install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-wayland.conf"
+}
+
# vim:set ts=2 sw=2 et: