summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--readme.install6
3 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f123ecc2be5..2fa7d47f8e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 8 13:38:17 UTC 2016
+# Wed Jun 8 13:42:00 UTC 2016
pkgbase = kodi-standalone-service
pkgdesc = Systemd service and user to run kodi in stand-alone mode
pkgver = 1.8
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.archlinux.org/index.php/Kodi#Kodi-standalone-service
install = readme.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 547d14270d5..162f60de7f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=kodi-standalone-service
pkgver=1.8
-pkgrel=3
+pkgrel=4
pkgdesc="Systemd service and user to run kodi in stand-alone mode"
# Arch ARM users do NOT attempt to use this package on Arch ARM!
# This is only for x86_64 and i686. You have been warned.
diff --git a/readme.install b/readme.install
index 92a5cf9d6c2..24bdac1a257 100644
--- a/readme.install
+++ b/readme.install
@@ -42,7 +42,7 @@ post_upgrade() {
echo "cp -a /var/lib/xbmc/.xbmc/* /var/lib/kodi/.kodi"
echo "chown -R kodi:kodi /var/lib/kodi"
fi
-
+
if [ "$(vercmp $2 1.8-1)" -lt 1 ]; then
if [[ -f /etc/X11/Xwrapper.config ]]; then
echo '-> It is no longer necessary to keep /etc/X11/Xwrapper.config for kodi to start properly.'
@@ -66,6 +66,8 @@ pre_install() {
else
/bin/true
fi
+ else
+ /bin/true
fi
if [ -f /usr/lib/systemd/system/kodi.service]; then
@@ -76,5 +78,7 @@ pre_install() {
else
/bin/true
fi
+ else
+ /bin/true
fi
}