summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD49
-rw-r--r--readme.install4
3 files changed, 28 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06017a2d2231..e277d75fd80d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,21 @@
pkgbase = kodi-standalone-service
pkgdesc = Systemd service to run kodi in stand-alone mode without a DE
pkgver = 1.107
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/graysky2/kodi-standalone-service
install = readme.install
arch = x86_64
license = MIT
- source = kodi-standalone-service-v1.107.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.107.tar.gz
- b2sums = e28940bb2a19e55e3ff0115f45416235532272473a7f6e07d96f3d8b6162cbf67581347ea11239e9e98b6ce58170c8df6a8a12ad9bcc025f3bb39b87a3dc04e8
-
-pkgname = kodi-standalone-x11-service
- depends = kodi-x11
- depends = polkit
- depends = xorg-server
- depends = xorg-xinit
- provides = kodi-standalone-service
- conflicts = kodi-standalone-service
- replaces = kodi-standalone-service
-
-pkgname = kodi-standalone-gbm-service
- depends = kodi-gbm
depends = polkit
depends = libinput
- provides = kodi-standalone-service
+ optdepends = cage: for kodi-wayland.service
+ optdepends = xorg-server: for kodi-x11.service
+ optdepends = xorg-xinit: for kodi-x11.service
+ replaces = kodi-standalone-x11-service
+ replaces = kodi-standalone-gbm-service
+ replaces = kodi-standalone-wayland-service
+ source = kodi-standalone-service-v1.107.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v1.107.tar.gz
+ b2sums = 8e668b77bc70bca8ec8f32e5af8955e6d8c5b96a2dda6f4ff5b11ed3210aa510c22d0813185afe8a38a7f8538f58a899f18403716d18e8c31662da3dbd4e26ae
-pkgname = kodi-standalone-wayland-service
- depends = kodi-wayland
- depends = polkit
- depends = libinput
- depends = cage
- provides = kodi-standalone-service
+pkgname = kodi-standalone-service
diff --git a/PKGBUILD b/PKGBUILD
index 9318f82bbe46..ac74cda048b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
-pkgbase=kodi-standalone-service
-pkgname=(kodi-standalone-x11-service kodi-standalone-gbm-service kodi-standalone-wayland-service)
+pkgname=kodi-standalone-service
pkgver=1.107
-pkgrel=5
+pkgrel=6
pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
# Do NOT attempt to use this package on Arch ARM! This is only for x86_64.
# You have been warned.
@@ -11,39 +10,23 @@ arch=('x86_64')
url="https://github.com/graysky2/kodi-standalone-service"
license=('MIT')
install=readme.install
-source=("$pkgbase-v$pkgver.tar.gz::https://github.com/graysky2/$pkgbase/archive/v$pkgver.tar.gz")
-b2sums=('e28940bb2a19e55e3ff0115f45416235532272473a7f6e07d96f3d8b6162cbf67581347ea11239e9e98b6ce58170c8df6a8a12ad9bcc025f3bb39b87a3dc04e8')
-
-package_kodi-standalone-x11-service() {
- replaces=('kodi-standalone-service')
- conflicts=('kodi-standalone-service')
- provides=('kodi-standalone-service')
- depends=('kodi-x11' 'polkit' 'xorg-server' 'xorg-xinit')
-
- cd "$pkgbase-$pkgver"
+depends=('polkit' 'libinput')
+replaces=('kodi-standalone-x11-service' 'kodi-standalone-gbm-service' 'kodi-standalone-wayland-service')
+optdepends=(
+ 'cage: for kodi-wayland.service'
+ 'xorg-server: for kodi-x11.service'
+ 'xorg-xinit: for kodi-x11.service'
+)
+source=("$pkgname-v$pkgver.tar.gz::https://github.com/graysky2/$pkgname/archive/v$pkgver.tar.gz")
+b2sums=('8e668b77bc70bca8ec8f32e5af8955e6d8c5b96a2dda6f4ff5b11ed3210aa510c22d0813185afe8a38a7f8538f58a899f18403716d18e8c31662da3dbd4e26ae')
+
+package() {
+ cd "$pkgname-$pkgver"
install -Dm644 init/kodi-x11.service "$pkgdir/usr/lib/systemd/system/kodi-x11.service"
- install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-x11.conf"
- install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-x11.conf"
-}
-
-package_kodi-standalone-gbm-service() {
- depends=('kodi-gbm' 'polkit' 'libinput')
- provides=('kodi-standalone-service')
-
- cd "$pkgbase-$pkgver"
install -Dm644 init/kodi-gbm.service "$pkgdir/usr/lib/systemd/system/kodi-gbm.service"
- install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-gbm.conf"
- install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-gbm.conf"
-}
-
-package_kodi-standalone-wayland-service() {
- depends=('kodi-wayland' 'polkit' 'libinput' 'cage')
- provides=('kodi-standalone-service')
-
- cd "$pkgbase-$pkgver"
install -Dm644 init/kodi-wayland.service "$pkgdir/usr/lib/systemd/system/kodi-wayland.service"
- install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-wayland.conf"
- install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-wayland.conf"
+ install -Dm644 init/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi-standalone.conf"
+ install -Dm644 init/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi-standalone.conf"
}
# vim:set ts=2 sw=2 et:
diff --git a/readme.install b/readme.install
index 96d6e3ab85d7..e384598d903f 100644
--- a/readme.install
+++ b/readme.install
@@ -1,5 +1,5 @@
post_remove() {
- echo "--> Optionally remove /var/lib/kodi/"
+ echo "--> Optionally remove /var/lib/kodi/ if you wish to remove all data too"
}
post_install() {
@@ -11,7 +11,7 @@ post_install() {
post_upgrade() {
if find /etc/systemd/system -type l -name 'kodi.service'|grep . &>/dev/null; then
echo '--> kodi.service is now kodi-x11.service'
- echo '--> you must disable the old one and enable the new one'
+ echo '--> manually disable the old one and enable the new one'
fi
}