summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--readme.install58
3 files changed, 18 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b356a8229f8e..8a7ff67d4c0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 31 01:33:50 UTC 2017
+# Sun Aug 6 09:37:08 UTC 2017
pkgbase = kodi-standalone-service
pkgdesc = Systemd service to run kodi in stand-alone mode without a DE
- pkgver = 1.91
+ pkgver = 1.92
pkgrel = 1
url = https://github.com/graysky2/kodi-standalone-service
install = readme.install
@@ -15,8 +15,8 @@ pkgbase = kodi-standalone-service
depends = kodi
depends = polkit
replaces = xbmc-standalone-service
- source = https://github.com/graysky2/kodi-standalone-service/archive/v1.91.tar.gz
- sha256sums = 08a21c0697a2669f2cfc2aaacaa21515068cfd33a7d1b42ce9b2590a996e1329
+ source = https://github.com/graysky2/kodi-standalone-service/archive/v1.92.tar.gz
+ sha256sums = 7660dd6d667895dd08486303aacc9d84726a815c7ca20e024ffc2ae634fa9328
pkgname = kodi-standalone-service
diff --git a/PKGBUILD b/PKGBUILD
index e528616cadba..e7a598ad9831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
pkgname=kodi-standalone-service
-pkgver=1.91
+pkgver=1.92
pkgrel=1
pkgdesc="Systemd service to run kodi in stand-alone mode without a DE"
# Do NOT attempt to use this package on Arch ARM! This is only for x86_64/i686.
@@ -13,7 +13,7 @@ depends=('systemd' 'xorg-server' 'xorg-xinit' 'kodi' 'polkit')
replaces=('xbmc-standalone-service')
install=readme.install
source=("https://github.com/graysky2/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('08a21c0697a2669f2cfc2aaacaa21515068cfd33a7d1b42ce9b2590a996e1329')
+sha256sums=('7660dd6d667895dd08486303aacc9d84726a815c7ca20e024ffc2ae634fa9328')
package() {
install -Dm644 "$srcdir/$pkgname-$pkgver/init/kodi.service" \
diff --git a/readme.install b/readme.install
index 48064ed5c3c4..3fe317b8871e 100644
--- a/readme.install
+++ b/readme.install
@@ -9,12 +9,11 @@ post_install() {
chown -R kodi:kodi /var/lib/kodi/.kodi
fi
- echo ">> Some drivers including Xorg's native modesetting may require the addition"
- echo ">> of /etc/X11/Xwrapper.config for X to initialize. If kodi.service fails to"
- echo ">> start, create that file containing the following single line:"
- echo ">> needs_root_rights = yes"
- echo ">>"
- echo ">> See: https://wiki.archlinux.org/index.php/Xorg#Rootless_Xorg_.28v1.16.29"
+ echo "==> Some drivers including Xorg's native modesetting may require the addition"
+ echo "==> of /etc/X11/Xwrapper.config for X to initialize. If kodi.service fails to"
+ echo "==> start, create that file containing the following single line:"
+ echo "==> needs_root_rights = yes"
+ echo "==> See: https://wiki.archlinux.org/index.php/Xorg#Rootless_Xorg_.28v1.16.29"
}
post_upgrade() {
@@ -25,52 +24,19 @@ post_upgrade() {
if ! id -u kodi | grep 420 > /dev/null 2>&1; then
usermod -u 420 kodi > /dev/null 2>&1
if [[ $? -ne 0 ]]; then
- echo "Changing uid of user kodi failed."
- echo "It is recommended that the uid is changed."
- echo "Stop all processes running under the kodi user and reinstall kodi"
- echo "or change the uid manually. (usermod -u 420 kodi)"
+ echo "==> Changing uid of user kodi failed."
+ echo "==> It is recommended that the uid is changed."
+ echo "==> Stop all processes running under the kodi user and reinstall kodi"
+ echo "==> or change the uid manually. (usermod -u 420 kodi)"
fi
chown -R kodi:kodi /var/lib/kodi
fi
-
- if [[ -d /var/lib/xbmc ]]; then
- echo "If you are upgrading from xbmc->kodi and wish to keep your"
- echo "settings, simply follow these steps after the install:"
- echo
- echo "cp -a /var/lib/xbmc/.xbmc/* /var/lib/kodi/.kodi"
- echo "chown -R kodi:kodi /var/lib/kodi"
- fi
}
post_remove() {
- getent passwd kodi > /dev/null 2>&1 && userdel kodi
- getent group kodi > /dev/null 2>&1 && groupdel kodi
-}
-
-pre_install() {
- if [ -f /usr/lib/systemd/system/xbmc.service ]; then
- /usr/bin/systemctl status xbmc.service &>/dev/null
- if [[ $? -eq 0 ]]; then
- # xbmc is running via this service
- /usr/bin/systemctl stop xbmc.service &>/dev/null
- else
- /bin/true
- fi
- else
- /bin/true
- fi
-
- if [ -f /usr/lib/systemd/system/kodi.service ]; then
- /usr/bin/systemctl status kodi.service &>/dev/null
- if [[ $? -eq 0 ]]; then
- # kodi is running via this service
- /usr/bin/systemctl stop kodi.service &>/dev/null
- else
- /bin/true
- fi
- else
- /bin/true
- fi
+ echo "==> Delete the kodi user if you are certain no processes are running under it."
+ echo "==> userdel kodi"
+ echo "==> groupdel kodi"
}
# vim:set ts=2 sw=2 et: