summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 13 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f8a8083bb9e..e23fdc48e757 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,22 @@
pkgbase = koi-git
pkgdesc = Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop
pkgver = 0.2.4.r0.geae87d1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/baduhai/Koi
arch = x86_64
arch = aarch64
license = LGPL3
- makedepends = git
makedepends = gcc
makedepends = qt5-base
makedepends = qt5-tools
makedepends = qt5-svg
makedepends = cmake
makedepends = extra-cmake-modules
- depends = gcc-libs
- depends = glibc
depends = plasma-integration
depends = plasma-framework5
- depends = kcoreaddons5
- depends = kconfig5
- depends = kwidgetsaddons5
- depends = kwindowsystem5
- depends = kconfigwidgets5
- depends = kxmlgui5
depends = hicolor-icon-theme
- depends = qt5-base
- optdepends = desktop-file-utils: Command line utilities for working with desktop entries
optdepends = xsettingsd: Apply settings to GTK applications on the fly
- provides = koi
+ provides = koi-0.2.4.r0.geae87d1
conflicts = koi
source = Koi-0.2.4.r0.geae87d1::git+https://github.com/baduhai/Koi.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 02457bcdcd45..f809c7637aa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,46 +6,38 @@ pkgname='koi-git'
_pkgname='koi'
__pkgname='Koi'
pkgver=0.2.4.r0.geae87d1
-pkgrel=2
+pkgrel=3
pkgdesc="Scheduled LIGHT/DARK Theme Switching for the KDE Plasma Desktop"
arch=('x86_64' 'aarch64')
url="https://github.com/baduhai/Koi"
license=('LGPL3')
-depends=('gcc-libs' 'glibc' 'plasma-integration' 'plasma-framework5' 'kcoreaddons5' 'kconfig5'
- 'kwidgetsaddons5' 'kwindowsystem5' 'kconfigwidgets5' 'kxmlgui5' 'hicolor-icon-theme' 'qt5-base')
-makedepends=('git' 'gcc' 'qt5-base' 'qt5-tools' 'qt5-svg' 'cmake' 'extra-cmake-modules')
-optdepends=('desktop-file-utils: Command line utilities for working with desktop entries'
- 'xsettingsd: Apply settings to GTK applications on the fly')
-provides=('koi')
+depends=('plasma-integration' 'plasma-framework5' 'hicolor-icon-theme')
+makedepends=('gcc' 'qt5-base' 'qt5-tools' 'qt5-svg' 'cmake' 'extra-cmake-modules')
+optdepends=('xsettingsd: Apply settings to GTK applications on the fly')
+provides=("${_pkgname}-${pkgver}")
conflicts=('koi')
source=("${__pkgname}-${pkgver}::git+https://github.com/baduhai/Koi.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${__pkgname}-${pkgver}"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g' ||
-
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
- )
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
mkdir -p "${srcdir}/${__pkgname}-${pkgver}/src/build/"
+}
+build() {
cmake -S "${srcdir}/${__pkgname}-${pkgver}/src/" \
-B "${srcdir}/${__pkgname}-${pkgver}/src/build/" \
-DCMAKE_INSTALL_PREFIX=/usr/
- cd "${srcdir}/${__pkgname}-${pkgver}/src/build/"
-
- make all
+ make -C "${srcdir}/${__pkgname}-${pkgver}/src/build/" all
}
package() {
- cd "${srcdir}/${__pkgname}-${pkgver}/src/build/"
-
- make DESTDIR="${pkgdir}" install all
+ make -C "${srcdir}/${__pkgname}-${pkgver}/src/build/" DESTDIR="${pkgdir}" install
install -Dm644 "${srcdir}/${__pkgname}-${pkgver}/src/koi.desktop" -t "${pkgdir}/usr/share/applications/"
}