summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 32 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22b84c771d96..cee0e420f5cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
# Generated by mksrcinfo v8
-# Sun Oct 23 23:47:18 UTC 2016
+# Mon Nov 13 16:03:35 UTC 2017
pkgbase = koku-xinput-wine
- pkgdesc = Adds xinput support to Wine, without modifying the source binaries of Wine.
- pkgver = 2016.03.25.ca7cd49
+ pkgdesc = Adds xinput support to Wine without modifying the source binaries of Wine.
+ pkgver = 1.2.1
pkgrel = 1
url = https://www.github.com/KoKuToru/koku-xinput-wine
arch = i686
arch = x86_64
- license = GPL3
- makedepends = git
+ license = custom:BSD2
makedepends = cmake
- depends = sdl2
- depends = lib32-sdl2
- depends = lib32-glibc
- source = koku-xinput-wine::git://github.com/KoKuToru/koku-xinput-wine
- md5sums = SKIP
+ makedepends = wine
+ conflicts = koku-xinput-wine-git
+ source = koku-xinput-wine::https://www.github.com/KoKuToru/koku-xinput-wine/archive/v1.2.1.tar.gz
+ md5sums = c38ec13596471bdc46b1bea12b60a525
+ depends_i686 = sdl2
+ depends_x86_64 = lib32-sdl2
+ makedepends_x86_64 = gcc-multilib
pkgname = koku-xinput-wine
diff --git a/PKGBUILD b/PKGBUILD
index 2ef5109b4348..b4292444aa46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,35 @@
# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
pkgname=koku-xinput-wine
-pkgver=2016.03.25.ca7cd49
+pkgver=1.2.1
pkgrel=1
-pkgdesc="Adds xinput support to Wine, without modifying the source binaries of Wine."
+_srcname="${pkgname}-${pkgver}"
+pkgdesc="Adds xinput support to Wine without modifying the source binaries of Wine."
arch=('i686' 'x86_64')
url="https://www.github.com/KoKuToru/koku-xinput-wine"
-license=('GPL3')
-makedepends=('git' 'cmake')
-depends=('sdl2' 'lib32-sdl2' 'lib32-glibc')
-source=("$pkgname::git://github.com/KoKuToru/koku-xinput-wine")
-md5sums=('SKIP')
+license=('custom:BSD2')
+conflicts=("${pkgname}-git")
-pkgver() {
- cd "$pkgname"
- git log -1 --format="%cd.%h" --date=short | sed 's:-:.:g'
-}
+makedepends=('cmake' 'wine')
+makedepends_x86_64=('gcc-multilib')
+depends_x86_64=('lib32-sdl2')
+depends_i686=('sdl2')
+
+source=("${pkgname}::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('c38ec13596471bdc46b1bea12b60a525')
build() {
- cd "$pkgname"
+ cd "${srcdir}/${_srcname}"
cmake .
make
}
package() {
- cd "$pkgname"
- install -Dm755 koku-xinput-wine.so "$pkgdir/usr/lib32/koku-xinput-wine.so"
+ cd "${srcdir}/${_srcname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/BSD2"
+ if [ "$CARCH" == "x86_64" ]; then
+ install -Dm755 koku-xinput-wine.so koku-xinput-wine64.so -t "${pkgdir}/usr/lib32/"
+ else
+ install -Dm755 koku-xinput-wine.so -t "${pkgdir}/usr/lib/"
+ fi
}
+