summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22b84c771d96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Oct 23 23:47:18 UTC 2016
+pkgbase = koku-xinput-wine
+ pkgdesc = Adds xinput support to Wine, without modifying the source binaries of Wine.
+ pkgver = 2016.03.25.ca7cd49
+ pkgrel = 1
+ url = https://www.github.com/KoKuToru/koku-xinput-wine
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = lib32-sdl2
+ depends = lib32-glibc
+ source = koku-xinput-wine::git://github.com/KoKuToru/koku-xinput-wine
+ md5sums = SKIP
+
+pkgname = koku-xinput-wine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ef5109b4348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Thor M. K. Høgås <thor alfakrøll roht dott no>
+pkgname=koku-xinput-wine
+pkgver=2016.03.25.ca7cd49
+pkgrel=1
+pkgdesc="Adds xinput support to Wine, without modifying the source binaries of Wine."
+arch=('i686' 'x86_64')
+url="https://www.github.com/KoKuToru/koku-xinput-wine"
+license=('GPL3')
+makedepends=('git' 'cmake')
+depends=('sdl2' 'lib32-sdl2' 'lib32-glibc')
+source=("$pkgname::git://github.com/KoKuToru/koku-xinput-wine")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --format="%cd.%h" --date=short | sed 's:-:.:g'
+}
+
+build() {
+ cd "$pkgname"
+ cmake .
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 koku-xinput-wine.so "$pkgdir/usr/lib32/koku-xinput-wine.so"
+}