summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--runtime-fix.patch12
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f8ba802b9e..00a035ecfd60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = komanda-cli-git
pkgdesc = The Komanda Command-line IRC Client
- pkgver = v0.9.4.r24.g391040d
+ pkgver = 0.9.4.r32.g8596023
pkgrel = 1
url = https://github.com/mephux/komanda-cli
arch = x86_64
license = BSD
makedepends = go
+ makedepends = git
makedepends = dep
source = komanda-cli-git::git+https://github.com/mephux/komanda-cli.git
+ source = runtime-fix.patch
sha256sums = SKIP
+ sha256sums = 1ff96e713c35aed197ba11d4681836b53016b1a83ea950c20cbaaaf2c122a560
pkgname = komanda-cli-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 811cb6837ae7..30c3d63256de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=komanda-cli-git
-pkgver=v0.9.4.r29.gb5ba03b
+pkgver=0.9.4.r32.g8596023
pkgrel=1
pkgdesc='The Komanda Command-line IRC Client'
arch=(x86_64)
url='https://github.com/mephux/komanda-cli'
license=(BSD)
-makedepends=(go dep)
-source=("${pkgname}::git+https://github.com/mephux/komanda-cli.git")
-sha256sums=('SKIP')
+makedepends=(go git dep)
+source=("${pkgname}::git+https://github.com/mephux/komanda-cli.git"
+ "runtime-fix.patch")
+sha256sums=('SKIP'
+ '1ff96e713c35aed197ba11d4681836b53016b1a83ea950c20cbaaaf2c122a560')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
prepare() {
cd "${srcdir}/${pkgname}"
+ patch -p1 -i '../runtime-fix.patch'
+
install -m755 -d "${srcdir}/go/src/github.com/mephux/"
cp -a "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/mephux/komanda-cli"
}
diff --git a/runtime-fix.patch b/runtime-fix.patch
new file mode 100644
index 000000000000..4186eb0fc27b
--- /dev/null
+++ b/runtime-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/komanda.go b/komanda.go
+index 7bd5ad6..7ce2f7a 100644
+--- a/komanda.go
++++ b/komanda.go
+@@ -6,7 +6,6 @@ import (
+ "log"
+ "os"
+ "path"
+- "runtime"
+
+ "github.com/mephux/common"
+ "github.com/mephux/komanda-cli/komanda"