summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07e4c096625c..1f55a06fec86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = kompose-bin
pkgdesc = Takes a Docker Compose file and translates it into Kubernetes resources
- pkgver = 1.20.0
+ pkgver = 1.26.0
pkgrel = 1
url = http://kompose.io/
arch = x86_64
license = Apache
- source_x86_64 = kompose-1.20.0.tar.gz::https://github.com/kubernetes/kompose/releases/download/v1.20.0/kompose-linux-amd64.tar.gz
- sha256sums_x86_64 = 66b8785fec6113a36d120c5b171bbef9346e7d801b712a9e2d12e15f3e4b9741
+ source_x86_64 = kompose-1.26.0.tar.gz::https://github.com/kubernetes/kompose/releases/download/v1.26.0/kompose-linux-amd64.tar.gz
+ sha256sums_x86_64 = ee2d8e15b0887b22fb4e0ac59db9d787d7670d4c424d7765c85ab1595f840674
pkgname = kompose-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index e51037627747..3cec8dc92275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,22 @@
pkgname=kompose-bin
_srcname=kompose
-pkgver=1.20.0
+pkgver=1.26.0
pkgrel=1
pkgdesc="Takes a Docker Compose file and translates it into Kubernetes resources"
url="http://kompose.io/"
license=('Apache')
arch=('x86_64')
-
source_x86_64=("$_srcname-$pkgver.tar.gz::https://github.com/kubernetes/kompose/releases/download/v$pkgver/kompose-linux-amd64.tar.gz")
-sha256sums_x86_64=('66b8785fec6113a36d120c5b171bbef9346e7d801b712a9e2d12e15f3e4b9741')
-
+sha256sums_x86_64=('ee2d8e15b0887b22fb4e0ac59db9d787d7670d4c424d7765c85ab1595f840674')
package() {
cd ${srcdir}
tar -xzf $_srcname-$pkgver.tar.gz
install -Dm755 "$srcdir/kompose-linux-amd64" "$pkgdir/usr/bin/kompose"
+
+ install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
+ install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
+ "$pkgdir/usr/bin/kompose" completion bash > "$pkgdir/usr/share/bash-completion/completions/kompose"
+ "$pkgdir/usr/bin/kompose" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_kompose"
}