summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bb6f74d080d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Thu Feb 2 09:08:23 UTC 2017
+pkgbase = kompose
+ pkgdesc = Takes a Docker Compose file and translates it into Kubernetes resources
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://kompose.io/
+ arch = x86_64
+ license = Apache
+ source_x86_64 = https://github.com/kubernetes-incubator/kompose/releases/download/v0.2.0/kompose-linux-amd64
+ md5sums_x86_64 = a4039136b79c2073177e5d9d2ca12516
+
+pkgname = kompose
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c0a8db075b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Simon Weald <simon[at]simonweald[dot]com>
+
+pkgname=kompose
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Takes a Docker Compose file and translates it into Kubernetes resources"
+url="http://kompose.io/"
+license=('Apache')
+arch=('x86_64')
+[ "$CARCH" = 'x86_64' ] && _arch='linux-amd64'
+
+source_x86_64=("https://github.com/kubernetes-incubator/kompose/releases/download/v$pkgver/kompose-linux-amd64")
+md5sums_x86_64=('a4039136b79c2073177e5d9d2ca12516')
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-$_arch" "$pkgdir/usr/bin/$pkgname"
+}