summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD13
3 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc4b7f61b02e..a84ebef4ab56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = kotlin-language-server-git
pkgdesc = Smart code completion, diagnostics and more for Kotlin using the Language Server Protocol
- pkgver = r868.c2aec4e
+ pkgver = r1444.80fc538
pkgrel = 1
- url = https://github.com/fwcd/KotlinLanguageServer.git
+ url = https://github.com/fwcd/kotlin-language-server.git
arch = any
license = MIT
- makedepends = java-environment=14
+ makedepends = java-environment=11
makedepends = git
- depends = java-runtime=14
+ depends = java-runtime=11
provides = kotlin-language-server
conflicts = kotlin-language-server
- source = kotlin-language-server::git+https://github.com/fwcd/KotlinLanguageServer.git
+ source = kotlin-language-server::git+https://github.com/fwcd/kotlin-language-server.git
sha256sums = SKIP
pkgname = kotlin-language-server-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c965cda0fe0c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+kotlin-language-server/
+*.pkg.tar
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 3e2a1c48e7ac..f668a3cc6035 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Ricardo Grim Cabrita <grimkriegor@krutt.org>
+# Maintainer: Ricardo Grim Cabrita <grim@kriegor.net>
pkgname=kotlin-language-server-git
_pkgname=kotlin-language-server
-pkgver=r868.c2aec4e
+pkgver=r1444.80fc538
pkgrel=1
pkgdesc="Smart code completion, diagnostics and more for Kotlin using the Language Server Protocol"
arch=(any)
-url="https://github.com/fwcd/KotlinLanguageServer.git"
+url="https://github.com/fwcd/kotlin-language-server.git"
license=('MIT')
conflicts=('kotlin-language-server')
provides=('kotlin-language-server')
-depends=('java-runtime=14')
-makedepends=('java-environment=14' 'git')
+depends=('java-runtime=11')
+makedepends=('java-environment=11' 'git')
source=("${_pkgname}::git+${url}")
sha256sums=('SKIP')
@@ -23,7 +23,8 @@ pkgver() {
}
build() {
- export JAVA_HOME="/usr/lib/jvm/java-14-openjdk"
+ jdk="$(find /usr/lib/jvm -maxdepth 1 -name "*11*jdk" | head -1)" &&
+ test -n "$jdk" && export JAVA_HOME="$jdk"
cd "${srcdir}/${_pkgname}"
./gradlew server:installDist
}